[FFmpeg-user] Playing an uncompressed raw interlaced RTP video stream

Carl Eugen Hoyos ceffmpeg at gmail.com
Sat Sep 29 02:33:20 EEST 2018

2018-09-28 16:38 GMT+02:00, villastar at yahoo.com.au
<villastar-at-yahoo.com.au at ffmpeg.org>:
>  On Friday, 28 September 2018, 6:01:08 am AWST, Carl Eugen Hoyos
> <ceffmpeg at gmail.com> wrote:
>> Please do, if it works your problem should be solved,
>> I fear though that the "bitpacked" codec (the name alone
>> makes me shiver) is broken and needs major changes.
> In the past, we have used the same command to playback a raw
> uncompressed, non-interlaced RTP stream before with success. It is
> only when we tried it with an interlaced version that we encountered
> this problem.
> I also got around to trying the filter today - the playback still isn't
> quite right.

This is what I feared.
The way the progressive decoding was implemented is broken so
much that it may not be trivial to fix.

Feel free to open a ticket on trac.

Carl Eugen

More information about the ffmpeg-user mailing list