[FFmpeg-user] Please streaming over nginx

Moritz Barsnick barsnick at gmx.net
Wed Aug 7 10:42:46 EEST 2019

On Wed, Aug 07, 2019 at 13:29:06 +0700, Phat Nguyentan wrote:
> I use openwrt and ffmpeg without h264 and libx264.  try to create m3u8 file
> on nginx. I run command:
> ffmpeg -loglevel verbose -re -i /dev/video0 -acodec libmp3lame -ar 44100
> -ac 1 -f flv rtmp://localhost:1935/hls/movi
> It's not working, can't create m3u8 file.

"It's not working" is a very short report. It helps if you post the
complete, uncut console output. (Why would the format flv create an
m3u8? Or do you mean nginx creates the m3u8?)

Seeing that you already figured out that it's the missing codec: Have
you tried a different one? ffmpeg's default codec for flv should be
"flv1", and that is supported natively, without external libraries.

> -vcodec h264, it's working, but on openwrt we don't have codecs.

No codecs *at all*? You mean ffmpeg has no video encoders? Please show
us the output of
$ ffmpeg -codecs



More information about the ffmpeg-user mailing list