[FFmpeg-user] h264_v4l2m2m Failed to set gop size: Invalid argument

Andriy Gelman andriy.gelman at gmail.com
Fri Dec 11 03:57:23 EET 2020


On Fri, 11. Dec 00:03, Ram Shaffir wrote:
> Hello,
> I'm using RPI4 running RaspiOS 64bit:
> Linux Dev64b 5.4.79-v8+ #1373 SMP PREEMPT Mon Nov 23 13:32:41 GMT 2020 aarch64 GNU/Linux
> I compiled FFmpeg ver 4.3 from this git:
> git clone --depth 1 --branch release/4.3 https://github.com/FFmpeg/FFmpeg.git
> (I realized after the build that I used the '--enable-nonfree' as I was following a walkthrough tutorial and copy/paste some of the configuration params; I'm planning on rebuilding it without '--enable-nonfree')

> my goal is to capture a video stream from a webcam to a file; however, I can't find the right parameters to have the video output played in "dumb" video players; most of the players show a black image or the first frame; I tried to add the following parameters but got the same result:

Does it work in ffplay? 

For debugging you may want to simplify the problem. Try to encode another video with
Does a software encoder work with v4l2 input?

> I searched for the error: " Failed to set gop size: Invalid argument " when using the h264_v4l2m2m encoder but didn't find anything I can use to fix it; I would be very grateful if you could help me with this issue.

This means that the parameter is not supported on the hardware encoder.
Nothing to be concerned about.


More information about the ffmpeg-user mailing list