[FFmpeg-user] ffplay - Hikvision RTSP stream on Wan

Moty.Hevroni Moty.Hevroni at hikvision.com
Mon Dec 28 13:07:48 EET 2020

Dear ffmpeg support team,
I would like to get your opinion on a problem that occurs when trying to open RTSP streams, of our cameras (Hikvision) via Wan:

When accessing the camera within the LAN, by command:
(ffplay -i rtsp://admin:pass@
The connection is working properly and the video window pop-up automatically.
So I connected the camera to a separate router, with proper port-forwarding (554 TCP + UDP),
then I tried to access it true WAN by command:
(ffplay -loglevel debug -i rtsp://admin:Test1234@,
and the following error occurred: (Note: VLC worked fine in both LAN and WAN)

root at kali:~# ffplay -loglevel debug -i rtsp://admin:Test1234@
ffplay version 4.3.1-5 Copyright (c) 2003-2020 the FFmpeg developers
  built with gcc 10 (Debian 10.2.0-15)
  configuration: --prefix=/usr --extra-version=5 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --arch=amd64 --enable-gpl --disable-stripping --enable-avresample --disable-filter=resample --enable-gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-libdav1d --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librabbitmq --enable-librsvg --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --disable-libsrt --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-lv2 --enable-omx --enable-openal --enable-opencl --enable-opengl --enable-sdl2 --enable-pocketsphinx --enable-libmfx --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libx264 --enable-shared
  libavutil      56. 51.100 / 56. 51.100
  libavcodec     58. 91.100 / 58. 91.100
  libavformat    58. 45.100 / 58. 45.100
  libavdevice    58. 10.100 / 58. 10.100
  libavfilter     7. 85.100 /  7. 85.100
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  7.100 /  5.  7.100
  libswresample   3.  7.100 /  3.  7.100
  libpostproc    55.  7.100 / 55.  7.100
Initialized opengl renderer.
[tcp @ 0x7fe104003040] No default whitelist set
[tcp @ 0x7fe104003040] Original list of addresses:
[tcp @ 0x7fe104003040] Address port 554
[tcp @ 0x7fe104003040] Interleaved list of addresses:
[tcp @ 0x7fe104003040] Address port 554
[tcp @ 0x7fe104003040] Starting connection attempt to port 554
[tcp @ 0x7fe104003040] Successfully connected to port 554
rtsp://admin:Test1234@ Invalid data found when processing input

The problem seems to occur only when trying to access the rtsp video stream via WAN.
Please advise, thanks.

Best Wishes

Moty Hevroni
Presales Engineer Israel Region

Mobile + 972 (0)52-833-4338
Email: Moty.Hevroni at hikvision.com
Website: www.hikvision.com<https://www.hikvision.com/en/>


CONFIDENTIALITY NOTICE: This electronic message is intended to be viewed only by the individual or entity to whom it is addressed. It may contain information that is privileged, confidential and exempt from disclosure under applicable law. Any dissemination, distribution or copying of this communication is strictly prohibited without our prior permission. If the reader of this message is not the intended recipient, or the employee or agent responsible for delivering the message to the intended recipient, or if you have received this communication in error, please notify us immediately by return e-mail and delete the original message and any copies of it from your computer system. For further information about Hikvision company. please see our website at www.hikvision.com<http://www.hikvision.com>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image003.jpg
Type: image/jpeg
Size: 12417 bytes
Desc: image003.jpg
URL: <https://ffmpeg.org/pipermail/ffmpeg-user/attachments/20201228/3dc754c2/attachment.jpg>

More information about the ffmpeg-user mailing list