[FFmpeg-user] Add logo to GPU transcoding UDP stream

Andy dssnosher at gmail.com
Mon Jan 13 05:53:43 EET 2020

When transcoding with CPU, adding -i /home/1.png -filter_complex
"[0:v][1:v] overlay=55:25" worked fine, but with GPU its throwing an
error msg

This is the command I tried using
ffmpeg -vsync 0 -hwaccel cuvid -c:v h264_cuvid -deint 1
-drop_second_field 1 -i 'udp://' -i /home/1.png
-filter_complex "[0:v][1:v] overlay=55:25" -c:v h264_nvenc -g 50 -vb
1300k -preset:v medium -bf 1 -c:a aac -bufsize 16M -aspect 16:9
-dts_delta_threshold 1000 -ac 2 -ar 48k -ab 96k 1.mp4

This results in
Input #0, mpegts, from 'udp://':
  Duration: N/A, start: 38678.701722, bitrate: N/A
  Program 108
      service_name    : YI NEWS
      service_provider: YI
    Stream #0:0[0x33a]: Video: h264 (Main) ([27][0][0][0] / 0x001B),
yuv420p(tv, bt709, top first), 1920x1080 [SAR 1:1 DAR 16:9], 25 fps,
50 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x39e](eng): Audio: mp2 ([3][0][0][0] / 0x0003), 48000
Hz, stereo, fltp, 192 kb/s
Input #1, png_pipe, from '/home/1.png':
  Duration: N/A, bitrate: N/A
    Stream #1:0: Video: png, rgba(pc), 50x50 [SAR 3780:3780 DAR 1:1],
25 tbr, 25 tbn, 25 tbc
Stream mapping:
  Stream #0:0 (h264_cuvid) -> overlay:main (graph 0)
  Stream #1:0 (png) -> overlay:overlay (graph 0)
  overlay (graph 0) -> Stream #0:0 (h264_nvenc)
  Stream #0:1 -> #0:1 (mp2 (native) -> aac (native))
Press [q] to stop, [?] for help
[mpegts @ 0x30c0dc0] Thread message queue blocking; consider raising
the thread_queue_size option (current value: 8)
Impossible to convert between the formats supported by the filter
'graph 0 input from stream 0:0' and the filter 'auto_scaler_0'
Error reinitializing filters!
Failed to inject frame into filter network: Function not implemented
Error while processing the decoded data for stream #1:0
[aac @ 0x30ec2c0] Qavg: 194.219
[aac @ 0x30ec2c0] 2 frames left in the queue on closing
Conversion failed!

How to solve this? Thank you.

More information about the ffmpeg-user mailing list