[FFmpeg-user] What argument(s) does 'ashowinfo' take?

Mark Filipak markfilipak.windows+ffmpeg at gmail.com
Tue Mar 3 01:59:30 EET 2020

On 03/02/2020 09:35 AM, Gyan Doshi wrote:
> On 02-03-2020 06:24 pm, Mark Filipak wrote:
>> On 03/01/2020 06:47 PM, Dan Bridges wrote:
>>> On 2/03/2020 9:12 am, Mark Filipak wrote:
>> This:
>> C:\CMD & tiny apps\ffmpeg >ffprobe -f lavfi 
>> amovie=G:\VIDEO_TS\VTS_01_1.VOB,ashowinfo
>> --note current working directory--
>> fails; "Error initializing filter 'movie' with args 
>> 'G:VIDEO_TSVTS_01_1.VOB'"
>> --note missing '\'s in path to 'VTS_01_1.VOB'--
>> And this:
>> C:\CMD & tiny apps\ffmpeg >ffprobe -f lavfi 
>> amovie=G:\\VIDEO_TS\\VTS_01_1.VOB,ashowinfo
>> --note escaped '\'s in path to 'VTS_01_1.VOB'--
>> fails; "movie=G:\\VIDEO_TS\\VTS_01_1.VOB,showinfo: No such file or 
>> directory".
> Double escape the : and use forward slashes
>      movie=G\\:/path/to/file


You're serious, aren't you? Ohmygod. Of course, it works.

...Thank you. I never, in a million years, would have tried that.

Is that a special case, simply for 'ashowinfo', or will I run into this 
sort of thing with other options & filters?

I think I'll have a drink now.

More information about the ffmpeg-user mailing list