[FFmpeg-user] Question on AVFoundation and importing from a DV-VCR

Colin Bitterfield colin at bitterfield.com
Fri Mar 27 17:52:13 EET 2020


Good Morning

I am using the Mac ports ffmpeg-devel version. I can compile it from scratch for testing.

The reason for trying to keep the original time stamps (which does not seem to happen) is I wanted Final Cut Pro to have the original scene information for splitting.

The tapes are from a video studio I acquired and I am going to remaster them for re-release. So I need the maximum quality from the take. 

I think the issue is related to ffmpeg taking a set of defaults based on the first stream detected and then there are multiple streams (at least 3 or 4) which require defaults to change.

My idea was to import the video raw to a file and then have FPCX do the import on the file. FCPX does not seem to work the same on a file as it does on controlling the deck for import.  

I am trying to streamline a workflow because after I finish 500 DV tapes I have another 500 8MM tapes to go.


Colin Bitterfield
colin at bitterfield.com

On March 27, 2020 at 3:49:14 AM, Thilo Borgmann (thilo.borgmann at mail.de) wrote:


> I have been trying to get a direct import from a Sony DSR-45 DV Deck. Using OS X Final Cut Pro hot annoying with various issues.
> Does anyone have suggestions or a method for doing this better? I have 500-600 more DV tapes to ingest.
> Using this command brings in a 12GB DVVIDEO files
> ffmpeg -hwaccel videotoolbox -hide_banner -benchmark_all -stats -loglevel error -f avfoundation -capture_raw_data true -pix_fmt 0rgb -i DV-VCR -t 600 -q 0  -c:v copy -c:a copy 'Test7.dv' -y
> The problem are:
> 1. The file is huge (Is there a way to auto split this with a scene detect filter? I have not tried this yet.
> 2 The videos I am working with consist of:
> a. Intro video track no audio
> b. 60 second intro (apparently with different time codes)
> c. A 45 minute to 60 minute video
> What I get is either the intro video is too slow or the actual video I want is too fast. It seems to depend on whether I start the tape before the intro text, or during a video. I am guessing different time codes.

sounds like different timestamps on the tape. Try to add a setpts filter if you don't need the original timestamps or try setting the output rate manually if you do (but I'm not sure about that...).

> I tried a number of test cases results varied but in all cases one or the other video was bad.
> My next round of testing will be with " -capture_raw_data false"

That _might_ solve your issues regarding the playback speed. It might result in loss of quality - assuming you're about to archive these several hundred tapes.

> I am running this on a MacBook Pro (10.15 Catalina) 
> ffmpeg version 4.2.git Copyright (c) 2000-2020 the FFmpeg developers
> built with Apple clang version 11.0.0 (clang-1100.0.33.17)

I'm still on Mojave and can't comment on Catalina. However, your build is too old to have the latest patches to avfoundation. Which are especially important for you because I fixed the end of recording bug. There is no release yet featuring it, get a build from after March 5th.

ffmpeg-user mailing list
ffmpeg-user at ffmpeg.org

To unsubscribe, visit link above, or email
ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".

More information about the ffmpeg-user mailing list