[FFmpeg-user] yadif-cuda issues

Kyle Schwarz zeranoe at gmail.com
Fri May 22 18:43:32 EEST 2020

On Fri May 22 2020 at 06:44:40 Andy Sheimo <asheimo at gmail.com> wrote:
> I tried to report this issue to Zeranoe's forums but they have since closed
> down and a message pointing to the official ffmpeg contact messages is in
> the forums place. Could you please advise if official support for
> Zeranoe's builds is available here or are windows users trying to use those
> builds out of luck?

So far I'm unable to reproduce this as apparently my GTX 1060 "is lacking
required capabilities". I tried:
> ffmpeg -hwaccel nvdec -hwaccel_output_format cuda -i i.mkv -vf yadif_cuda=0:-1:1 -c:v h264_nvenc o.mkv

On Tue Apr 21 2020 at 00:43:07, Dennis Mungai <dmngaie at gmail.com> wrote:
> I've seen a similar issue here on the "CUDA_ERROR_INVALID_IMAGE: device
> kernel image is invalid error" posted on this mailing list related to
> Zeranoe's builds.

I'm not able to find other mailing list posts that contain
"CUDA_ERROR_INVALID_IMAGE" related to the Zeranoe builds. There is however an
open bug that contains it (https://trac.ffmpeg.org/ticket/8457), which is not
Windows related.

If this is indeed a Windows/Zeranoe issue, it's rather specific and would
implicate my cross-compiler itself. I'll need to be able to reproduce this to
confirm, but you could try Rogers build script to see if it happens there too.

More information about the ffmpeg-user mailing list