[FFmpeg-user] Conflicts with yuv420 && yuvj444p on Ubuntu 20.ls

Victor Cardeal victorcardeal at gmail.com
Thu Nov 26 03:51:51 EET 2020

Hello, hope all fine there.

I'm facing some problem trying to convert a process video with CV2 to post
on instagram. This mediaSocial seems doesn't accept yuvj444p format pixels.
I realize this because when I up from webWhatsapp (same owner of Insta)
return me error like :
      erro: Error Code: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) Details:
auto mozilla::SupportChecker::AddMediaFormatChecker(const
mozilla::TrackInfo &)::(anonymous class)::operator()() const: Decoder may
not have the capability to handle the requested video format with YUV444
chroma subsampling.

So I run command above:
   ffmpeg -i outputvideoFri\ Nov\ \ 6\ 13\:48\:42\ 2020.mp4 -vf
scale=600x600 -format yuv420p -c:v libx264  output.mp4

But extrange behaviour occur. Again when I try to upload same error back.
when i run command:
   ffmpeg -i output.mp4
to check metadata values resulted print was:
        Duration: 00:00:11.36, start: 0.000000, bitrate: 3543 kb/s
    Stream #0:0(und): Video: h264 (High 4:4:4 Predictive) (avc1 /
0x31637661), yuvj444p(pc), 600x600, 3540 kb/s, 25 fps, 25 tbr, 12800 tbn,
50 tbc (default)
      handler_name    : VideoHandler

therefore any way to solve this questions?
Atenciosamente, Victor Cardeal.

More information about the ffmpeg-user mailing list