[FFmpeg-user] Integration of ffmpeg

Jim DeLaHunt list+ffmpeg-user at jdlh.com
Tue Aug 17 04:17:14 EEST 2021

On 2021-08-16 17:38, The Admin wrote:

> Hi,
>    Here the command that works fine at the command prompt.
> C:\progra~1\GloboTRAC\ffmpeg\bin\ffmpeg.exe -i a0.m3u8 -i a1.m3u8 -i
> a2.m3u8 -filter_complex
> "[0]adelay=0:all=1[0a];[1]adelay=17650:all=1[1a];[2]adelay=37510:all=1[2a];[0a][1a][2a]amix=inputs=3[a]"
> -map "[a]"  -y all_audio.mp4
> When I run the same command from the Process.Start command in C#, it just
> hangs.  I've even tried triggering the execution from .bat file and it
> hangs as well.
> If it is the subprocess, I am open to any suggestions.
> Any help would be appreciated.
> Marc.

It may be that FFmpeg is trying to interact with stdin, and the 
subprocess is not responding like a live shell would. Try adding the 
`-nostdin` option to your command line. See answer 
<https://stackoverflow.com/a/47114881/1099571> to question, "ffmpeg 
hangs when run in background".

If that answer helps you, consider upvoting it.

Best regards,
      —Jim DeLaHunt

More information about the ffmpeg-user mailing list