[FFserver-user] repair to ffserver after ubuntu 11 update

Brown Patrick-PMH786 Patrick.Brown at motorolasolutions.com
Tue Dec 13 23:34:17 CET 2011

When will ffserver.c be updated with the following fix?

You get a bind error see attached description. The fix does work.

Distribution: Ubuntu 11.10

Bind(port 8090): Invalid argument error in ffserver patch found


I was getting this error with ffserver failing to start on the latest
release on the latest Ubuntu(11.10) and still got it when I rolled back
to Ubuntu 10.04 LTS with the latest ffmpeg from git and also when I
tried an older release of ffmpeg. Lots of Googling yielded no answer
until I found this Russian site and thanks to Google Translate, was able
to read this patch. If you open ffserver.c in a text editor, and find
the text below(it is around line number 4000 or so), this is where
you'll make a small edit. Insert the line with the "+"(without including
the "+" of course) save the changes and recompile(make). It worked for


my_http_addr.sin_port = htons(val); 

 + my_http_addr.sin_family = AF_INET; 

 } else if (!strcasecmp(cmd, "BindAddress")) { 

 get_arg(arg, sizeof(arg), &p); 

 if (resolve_host(&my_http_addr.sin_addr, arg) != 0) {




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/ffserver-user/attachments/20111213/a0af434c/attachment.html>

More information about the ffserver-user mailing list