[FFserver-user] ffserver - can't access the outgoing stream

Victor Petrescu victor.petrescu13 at gmail.com
Thu Mar 31 13:06:26 CEST 2011

Good day to all. I have a rather odd problem.

I configurated a ffserver and tried to used it to stream something from a

The commands were:

#mkfifo pipe.avi
#ffserver &
#ffmpeg -i pipe.avi -r 24 http://localhost:8090/feed1.ffm
#mplayer -dumpstream rtp:// -dumpfile pipe.avi (in another
terminal this one)

All worked fine for a while (except some little problems that don't bother
me any more) but now I can't see the stream (in a browser that embed the
result of the ffserver -> a swf).

To be more specific:
There are no errors (except this one [mpeg2video @
0x9094660]mpeg_decode_postinit() failure -> but I also got this error when
it was working good and it doesn't stop at it), the streaming start,
everything looks fine.

When I try to access it sometimes it works on at most 2 computers, sometimes
it does not work at all. The idea is to work on about 100 computers so the
"maybe works on 2 computers" is not really a solution.

The ffserver.conf is:

Port 8090


MaxHTTPConnections 200

MaxClients 200

MaxBandwidth 100000

CustomLog -


<Feed feed1.ffm>

File /tmp/feed1.ffm
FileMaxSize 16484
ACL allow


<Stream test.swf>
Feed feed1.ffm
Format swf
VideoFrameRate 24
VideoSize 480x352
VideoBitRate 5000
PreRoll 0

I'm sorry if I didn't describe the problem clearly (my English is not so
good)... for any clarifications just ask :)

Thank you for your time,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/ffserver-user/attachments/20110331/0bf5c541/attachment.html>

More information about the ffserver-user mailing list