[FFserver-user] working configuration for transcoding of mjpeg stream to h264

Rakesh Shivayya Guttedar -ERS, HCL Tech rakesh-sg at hcl.com
Wed Feb 1 10:21:20 CET 2012


I want to setup a streaming server using ffmpeg and ffserver.
I have an mjpeg feed from an IP camera as input. I need to transcode this to h264 using ffmpeg and restream it using ffserver.
Have any one tried this before?. What is the working configuration in ffserver conf file and ffmpeg command line?

This is what I have tried and so far I am not much successful.

Configuration in ffserver:

Port 8090
MaxHTTPConnections 2000
MaxClients 1000
MaxBandwidth 10000

<Feed feed1.ffm>
File /tmp/feed1.ffm
FileMaxSize 200K
ACL allow

<Stream test1.mp4>
Feed feed1.ffm
Format rtp

Ffmpeg command:
ffmpeg  -f mjpeg -i "http://cameraIP/videostream.cgi?user=something&pwd=something" -vpre lossless_ultrafast -vcodec libx264 -an  -r 27 -s 160x240

here is the output of the ffmpeg command:
[mjpeg @ 0x9cedb00] max_analyze_duration 5000000 reached at 5000000
[mjpeg @ 0x9cedb00] Estimating duration from bitrate, this may be inaccurate
Input #0, mjpeg, from '':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: mjpeg, yuvj422p, 320x240, 25 fps, 25 tbr, 1200k tbn, 25 tbc
[buffer @ 0x9e5b600] w:320 h:240 pixfmt:yuvj422p tb:1/1000000 sar:0/1 sws_param:
[scale @ 0x9e42e60] w:320 h:240 fmt:yuvj422p -> w:160 h:128 fmt:yuvj420p flags:0x4
[libx264 @ 0x9d02e40] VBV is incompatible with constant QP, ignored.
[libx264 @ 0x9d02e40] using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.1 Cache64
[libx264 @ 0x9d02e40] profile High 4:4:4 Predictive, level 1.1, 4:2:0 8-bit
Output #0, ffm, to '':
    encoder         : Lavf53.24.0
    Stream #0:0: Video: h264, yuvj420p, 160x128, q=10-51, 64 kb/s, 1000k tbn, 25 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (mjpeg -> libx264)
Press [q] to stop, [?] for help
[mjpeg @ 0x9cfda40] Found EOI before any SOF, ignoring
Found EOI before any SOF, ignoring 1916kB time=00:00:07.16 bitrate=2192.2kbits/s
Found EOI before any SOF, ignoring 6644kB time=00:00:24.96 bitrate=2180.6kbits/s dup=1 drop=0
Found EOI before any SOF, ignoring11400kB time=00:00:43.08 bitrate=2167.8kbits/s dup=2 drop=0
Found EOI before any SOF, ignoring19644kB time=00:01:13.32 bitrate=2194.8kbits/s dup=3 drop=0

Output of ffserver:
Wed Feb  1 14:43:03 2012 - - [GET] "/feed1.ffm HTTP/1.1" 200 4149
Wed Feb  1 14:43:20 2012 Error writing output header

Vlc Player is not able to play this stream.

Some inputs will be helpful to me.

Thanks and Regards,


The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and
attachments please check them for viruses and defect.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/ffserver-user/attachments/20120201/73daed2e/attachment.html>

More information about the ffserver-user mailing list