[Libav-user] Remuxing video file

Andrey Utkin andrey.krieger.utkin at gmail.com
Mon Feb 3 16:28:04 CET 2014

2014-02-02 Yuri Oleynikov (יורי אולייניקוב <yurkao at gmail.com>:
> Thanks, Stefano.
> Adding timestamp scaling partially solved the issue: in VLC everything work
> find, however in WMP12 only audio stream is played.
> Also tried with your remuxing code
> (http://ffmpeg.org/doxygen/trunk/doc_2examples_2remuxing_8c-example.html) -
> same result: no video playback.
> I thought that the problem is codec, but it seems to me that it's not the
> case because
>  * the code is just remuxing streams
>  * remuxing mp4->mp4 or mp4->megts produces correct output.
>  * the original mp4 file is played correctly in both VLC and WMP.

It happens that players play differently files created with different
video creating software.
You should try to figure out what exactly confuses WMP, and we'll see
if we can help it on level of ffmpeg or at application context.

Does it work in WMP if you remux via ffmpeg command line tool? What
ffprobe shows for output file?

Andrey Utkin

More information about the Libav-user mailing list