[Libav-user] Compiling ffmpeg for WinRT 8.1

Alexander Wischnewski aw.wisch at googlemail.com
Fri Jan 22 14:15:10 CET 2016


I am currently trying to compile ffmpeg libs for Windows Runtime (8.1) with
VS 2013 following the compilation guide. Everything worked well until i
reached the step to compile for "Windows Store 8.1 ARM".

While executing configure with the params shown in the guide it fails with
the error "Error running preprocessor at /usr/bin/gas-preprocessor.pl line
206.". I know this is related to perl / gas-preprocessor.pl and made sure
that both are installed and present in my MSYS2 path (e.g.

Here are the last few lines of the config.log file:

check_gas using 'gas-preprocessor.pl -arch arm -as-type armasm -- armasm'
as AS
BEGIN ./ffconf.8n8Gn4PI.S
    1 .macro m n, y:vararg=0
    2 \n: .int \y
    3 .endm
    4 m x
END ./ffconf.8n8Gn4PI.S
gas-preprocessor.pl -arch arm -as-type armasm -- armasm -D_ISOC99_SOURCE
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -Dstrtod=avpriv_strtod
-Dsnprintf=avpriv_snprintf -D_snprintf=avpriv_snprintf
-Dvsnprintf=avpriv_vsnprintf -nologo -ignore 4509
-march=armv7 -c -o ./ffconf.N3TiMVYr.o ./ffconf.8n8Gn4PI.S
Error running preprocessor at /usr/bin/gas-preprocessor.pl line 206.
GNU assembler not found, install/update gas-preprocessor

I checked the gas-preprocessor script at line 206, there is an OPEN call
which i guess is related to some file operation ?! So my first thought
would be there is a problem with file permissions. I tried running MSYS2
bash / VS command prompt / perl.exe as admin and made sure that file
permissions are set to full access for all windows users, but i always get
the same error. Now i am out of ideas.

Is there anything i am missing ?

Thanks in advance,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20160122/a0d0b66b/attachment.html>

More information about the Libav-user mailing list