[Libav-user] Windows compile can't find LAME

Jeremy Gregorio gunvalkyrie at yahoo.com
Sun Jul 8 19:46:17 EEST 2018

Hi All,      I built LAME 3.100 with Visual Studio 2015 using nmake (I had to edit the make file to change nasmw to just plain nasm but it compiled). I got a lib file (libmp3lame-static.lib) and a header file (lame.h).
      I put these in the /usr/lib and /usr/include folders of my MSYS2 install folder, fired up a Visual Studio command prompt and then fired up MSYS2 from there and ran the following configure:

 ./configure --toolchain=msvc --arch=i386 --enable-yasm --enable-asm --enable-static --disable-shared --enable-libx264 --enable-libmp3lame --enable-gpl --extra-ldflags=-L/usr/lib --extra-cflags=-I/usr/include/lame --host-ldflags=-L/user/lib   --extra-libs=-lm --extra-libs=-lpthreads

But it complains it can't find lame:
    ERROR: libmp3lame >= 3.98.3 not found
I tried renaming my lib file to just libmp3lame.lib but that didn't help. 

I also tried building lame inside MSYS2 with the regular /.configure && make && make install. This generates libmp3lame.la and libmp3lame.a files but these don't seem to be the right types. If I understand correctly (big 'if') these are gcc binaries. 

Does anyone know what I'm doing wrong? While I'm on the subject does anyone make pre-compiled library files :)? The Zeranoe build doesn't have the lib files for libav development. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20180708/0e50cba9/attachment.html>

More information about the Libav-user mailing list