[Ffmpeg-devel-irc] ffmpeg.log.20120120

burek burek021 at gmail.com
Sat Jan 21 02:05:01 CET 2012

[00:48] <jerro> Hi, does anyone here know if it's possible to stream webm with ffserver? How do I configure it to do that?
[01:08] <shevy> I can use ffmpeg to join several .mp3 files right?
[01:11] <treund> cat even
[01:22] <Randy_T> I want to use mplayer or mencoder as a source. This works great, except for sources with variable framerate. I can only do video or audio at once so I encode an audio file first, then video, then copy both to an mp4, or I could include the encoded audio while while encoding the video. Mencoder does a decent job with harddup but I still have a video file length of 24:30, and an audio file length of 24:23. So what I really
[01:22] <Randy_T>  want is some frames to be dropped so video syncs to audio. Would vsync be a solution here and could someone give me an example in this case? The following is my best guess but it drops all the frames: "-vsync -i pipe: -i aud.mp4 -map 0:0,1:0"
[01:25] <Randy_T> pipe: being the raw video output from mencoder. aud.mp4 being audio previously encoded with ffmpeg.
[03:07] <jerro> Does anyone here know if it's possible to stream html 5 webm with ffserver? If it is, how do I configure it to do that?
[07:52] <Arthur_D> for some reason, copying a file with ffmpeg and trimming it at the end with -t left me with no audible sound
[07:52] <Arthur_D> I used ffmpeg -i file.mpg -codec copy file2.mpg
[07:53] <Arthur_D> when looking at the codec info of the file in VLC, it has many audio channels and it gets more and more while I play the file
[07:55] <Arthur_D> so something is wrong, but I don't know how to remedy this unfortunate situation. Care to enlighten me? :)
[07:59] <Arthur_D> hm, importing it to PiTiVi works, sound and all... but when opening it in VLC and MPlayer, it doesn't give any sound
[09:33] <Arthur_D> still looking for an answer to my audio stream problem
[09:39] <sacarasc> Arthur_D: To quote the on join message:
[09:39] <sacarasc>  ¬ChanServ¬ [#ffmpeg] When asking a question be precise, detailed and patient. If you don't receive a response, try the users mailing list. PASTE TO http://ffmpeg.pastebin.com/ ! If you are asking about CLI usage, paste the complete command and output to the paste bin.
[09:42] <Arthur_D> well, it's not like I'm hogging the channel. Noone else has asked for help in the meantime
[09:42] <sacarasc> But you've not read it again.
[09:42] <sacarasc> Where is the pastebin of the output of ffmpeg?
[09:44] <Arthur_D> http://pastebin.com/RMYLff5E well it doesn't show anything wrong as far as I can see
[09:45] <Arthur_D> though I guess I better leave that for others to decide :)
[09:53] <rfx> Arthur_D: I don't see anything wrong but I'm just a user like you. The only thing I see is that your version about three months old, you might want to update that. What does ffmpeg -i on the new file show?
[09:55] <Arthur_D>   Duration: 00:10:27.99, start: 1.000000, bitrate: 2463 kb/s
[09:55] <Arthur_D>     Stream #0:0[0x1e0]: Video: mpeg2video (Main), yuv420p, 720x480 [SAR 8:9 DAR 4:3], 9000 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
[09:55] <Arthur_D>     Stream #0:1[0x80]: Audio: ac3, 48000 Hz, stereo, s16, 320 kb/s
[09:55] <Arthur_D> so everything seems to be in order
[09:56] <Arthur_D> yet VLC and MPlayer doesn't output any sound
[09:57] <rfx> Arthur_D: vlc has a log console somewhere, any output there maybe?
[09:59] <Arthur_D> not really, but when comparing the original, working file's "module tree" with the copy, there is no audio output in it
[10:00] <Arthur_D> funnily enough, it works all right, sound and everything when importing in PiTiVi video editor
[10:00] <rfx> I'd try latest ffmpeg just in case ..
[10:05] <Arthur_D> I'll try to upgrade it
[10:09] <Cervajz> Hello :)
[10:09] <Cervajz> Is it possible to switch off (avoid) continuity_check during openning TS file, please?
[10:11] <Cervajz> I am trying to open TS file and the "avformat_find_stream_info" function takes a lot of time
[10:35] <Arthur_D> rfx: updated ffmpeg, and the issue prevails
[12:00] <Arthur_D> alrighty, kinda fixed my issue
[12:01] <Arthur_D> used -target ntsc-dvd -vcodec copy to let it automatically choose audio stream output
[12:01] <Arthur_D> and thus, it works
[13:12] <Cervajz> Hello
[13:17] <Cervajz> How can I tell "avformat_find_stream_info" to do not probe private streams in TS, please?
[13:18] <Cervajz> This functions started to read whole TS file when it reaches my private stream
[13:18] <Cervajz> Then it takes very long time
[13:22] <Cervajz> The private streams are marked as "6"
[14:07] <rfx> Arthur_D: thanks for sharing, interesting.
[15:06] <Arthur_D> rfx: actually, when encoding with the aforementioned options, I got this in the terminal: Incompatible sample format 's16' for codec 'ac3', auto-selecting format 'flt'
[15:07] <Arthur_D> thus suggesting that using -acodec copy tried to use the wrong sample format
[15:09] <Arthur_D> anyway, it worked, and I'm happy ;)
[16:36] <IchGucksLive> Hi all im from Germany i try to find a way to get a AVCHD file from a MOV to play the video from a camcorder on a panasonic screen
[16:36] <IchGucksLive> there are 1000 google finds from MTS to  ... but not one to the other side
[16:37] <IchGucksLive> ffmpeg version git-2011-11-21-2c28e26
[16:39] <Mavrik> IchGucksLive, um... so you have a AVCHD file and you need to convert it to what exactly?
[16:39] <IchGucksLive> no the other way i got a MOV from Kodak Zi8
[16:40] <Mavrik> and you need to make an AVCHD file?
[16:40] <IchGucksLive> and i want that to play on a usb stick in a Panasonic flatscreen
[16:40] <IchGucksLive> Mavrik: yes
[16:41] <Mavrik> hmm... I'm not sure ffmpeg supports that... are your sure your Panasonic flatscreen doesn't support mp4 or something like that?
[16:42] <IchGucksLive> it says .ps
[16:42] <IchGucksLive> or .mts
[16:43] <IchGucksLive> i going to have a look at the handbok
[16:44] <IchGucksLive> AVCHD, MPEG2 und DivX as transport straem
[16:44] <Mavrik> IchGucksLive, it doesn't seem like ffmpeg supports AVCHD encoding
[16:44] <Mavrik> ah.
[16:44] <Mavrik> MPEG-2 is ok :)
[16:45] <IchGucksLive> the transport stream .ps is the container wright
[16:45] <Mavrik> .ps is program stream, transport streams are in .ts usually
[16:46] <Mavrik> IchGucksLive, ffmpeg.exe -i d:\Videos\MVI_0014.MOV.MP4 -codec:v mpeg2video -b:v 1500k -codec:a mp2 -b:a 128k test.ts
[16:47] <Mavrik> that should create a valid stream for the TV
[16:47] <IchGucksLive> im on ubuntu
[16:47] <IchGucksLive> thanks
[16:47] <Mavrik> you can also use "-codec:v libxvid" to encode to DivX for greater quality
[16:47] <Mavrik> (if you have it compiled)
[16:47] <Mavrik> change -b:v and -b:a parameters for bitrate for the quality you want
[16:48] <IchGucksLive> thanks i try this
[16:49] <rfx> Irritating nick :)
[17:14] <IchGucksLive> Mavrik:  thanks  i got the problem that libxvidcore4 is on the git ffmpeg but no -codec:v libxvid in codecs
[17:15] <IchGucksLive> http://ubuntuforums.org/showthread.php?t=1540254 i updated from medibuntu
[17:15] <IchGucksLive> but still no codec
[17:15] <IchGucksLive> do i need to recompile ffmpeg
[17:21] <IchGucksLive> do i need to restart the system for this ß
[17:21] <IchGucksLive> im going foer a restart
[17:28] <rhizmoe> going through the build flags, what's the practical difference between faac and vo_aacenc?
[18:37] <danverde> anyone using avformat / avcodec in with their own application?
[18:40] <danverde> is there an libav user channel?
[19:34] <teratorn> danverde: a lot of people use libavformat and libavcodec in their applications
[19:35] <danverde> I am wonder where to ask about a memory leak I get when trying to close my format/codev contexts
[19:36] <danverde> codec*
[19:36] <danverde> I call avformat_close_input but I still am seeing memory leaks
[19:36] <danverde> are there other "close" methods I need to be aware of?
[19:37] <teratorn> what is being leaked?
[19:37] <teratorn> and how do you know it's leaking?
[19:38] <danverde> well, that's not real clear to me.  I am developing with MSVC and precompiled libav libraries.
[19:38] <teratorn> maybe you need to call avcodec_close() on your AVCodecContext
[19:38] <danverde> ahh.  I am not doing that yet
[19:38] <danverde> I'll look at that
[19:38] <teratorn> I suggest developing on a real OS that can run valgrind
[19:39] <danverde> yeah. I may have to do that if codec close doesn't fix it for me
[19:44] <danverde> @teratron: that was it.  thx
[21:15] <mcbaine1>  Hi there ::: I'm really excited about going to FOSDEM  ... I put an advert in the national newspaper to see if anyone else is going and to get in touch etc... Anybody available for abit of travelling / FLOSS advice here atmo.   ??
[23:19] <mcbaine1> http://goo.gl/6knuF
[23:42] <maujhsn> What has to be enabled to get this screencast command to work?  http://pastebin.com/HF9KRCWE
[23:44] <microchip_> maujhsn: --enable-libx264
[23:45] <maujhsn> microchip_ I thought so!
[23:47] <maujhsn> microchip_ Is libx264 one of those "non-free" medibuntu packages from multi-verse?
[23:47] <microchip_> i don't know, i don't use *buntu
[23:48] <maujhsn> Can anybody else answer this question?
[23:49] <Guest50148> um
[23:50] <maujhsn> ummmmmmm!
[23:50] <Mavrik> there's no reason you'd need libx264 to make a screenshot O.o
[23:50] <Mavrik> you forgot to paste the actual command line you use
[23:50] <maujhsn> OK!
[23:50] <Mavrik> not to mention your ffmpeg version is beyond ancient
[23:50] <cbreak> x264 is non-free?
[23:50] <cbreak> maybe because it's GPL
[23:51] <Mavrik> no, x264 is GPL
[23:51] <cbreak> instead of LGPL like the rest of ffmpeg
[23:51] <Mavrik> probably some Ubuntu dev has an "opinion" about patents
[23:51] <Mavrik> but IIRC it shouldn't be classified as non-free
[23:52] <maujhsn> So how is this command modified? "ffmpeg -f alsa -ac 2 -i pulse -f x11grab -r 30 -s 1024x768 -i :0.0 -qscale 1 -acodec pcm_s161e  -vcodec libx264 -vpre lossless_ultrafast -threads 0 output.mkv".
[23:52] <Mavrik> um
[23:52] <Mavrik> what exactly are you trying to achieve?
[23:53] <maujhsn> screencast
[23:53] <Mavrik> ah.
[23:53] <maujhsn> ahhhh!
[23:53] <Mavrik> yuck, my mistake, I read "screenshot" -_-
[23:53] <maujhsn> screencast
[23:54] <Mavrik> maujhsn, anyway, your FFMpeg doesn't have libx264 compiled in and dates back to middle ages
[23:54] <maujhsn> and
[23:54] <Mavrik> update it to new version that has libx264 support compiled in
[23:54] <cbreak> if you want to do live recording, maybe something simple like motion jpeg is ok
[23:54] <cbreak> until you later compress it down to something more manageable
[23:55] <Mavrik> yea, or that - use mjpeg, since you're not compressing the audio either :)
[23:55] <maujhsn> So it is sudo apt-get ?
[23:56] <cbreak> you could git clone it :)
[23:56] <cbreak> (if you like compiling your software yourself)
[23:58] <maujhsn>  git clone it...Whats the command?
[00:00] --- Sat Jan 21 2012

More information about the Ffmpeg-devel-irc mailing list