[Ffmpeg-devel-irc] ffmpeg.log.20120121

burek burek021 at gmail.com
Sun Jan 22 02:05:01 CET 2012

[00:03] <cbreak> maujhsn: do you know how to compile a program?
[00:05] <maujhsn> cbreak I am using a liveUSB!
[00:05] <cbreak> then it's probably not for you :)
[00:06] <maujhsn> Do not know how to compile from liveUSB
[00:06] <maujhsn> bullshit!
[00:17] <teratorn> by default do timestamps on audio packets refer to the start or the end of the samples?
[00:19] <cbreak> I always expected it to mean the start
[00:21] <teratorn> that's my naive expectation too, but I'm looking at a system that captures audio in over half-second intervals, then encodes it using a timestamp generated from current system time
[00:21] <teratorn> so I'm expect it to be out of sync with the video, but it's not
[01:07] <Rango212> can anyone tell me what -strict experimental does?
[02:15] <desti> do i need to add some special option for vorbis? copied a vorbis sound out of a mkv video and now i can't scoll in the audio file
[02:21] <hallowicked> anybody know if its possible to output the logfile as a .xml
[02:59] <Arthur_D> I've got a file with slightly out-of-sync audio. How do I go about correcting it?
[03:20] <Arthur_D> found the solution :)
[03:24] <hallowicked> howd u do it Arthur_D
[03:25] <Arthur_D> well, it was the solution to my problem, so not sure if it applies ;)
[03:33] <hallowicked> heh so u figure it out and are asked how u did and dont wanna help others lol
[03:41] <Arthur_D> no, that was not what I meant. I saw you had asked a question, and my wording could be misunderstood to the point that you thought I found a solution to your problem, when I only found a solution to my own
[03:42] <Arthur_D> anyway, I used ffmpeg -itsoffset 00:00:00.6 -i inputfile -vcodec copy -acodec ac3 outputfile
[03:43] <Arthur_D> as per this how-to: http://howto-pages.org/ffmpeg/#delay
[03:58] <hallowicked> ahh cool
[03:58] <hallowicked> ya ive had sync issues also
[03:58] <hallowicked> especially after using  avidemux to edit commercials
[04:00] <Arthur_D> haha
[04:01] <hallowicked> u know any .tcl by chance hehe
[04:01] <Arthur_D> funnily enough, I needed to resync after using avidemux
[04:01] <hallowicked> ya avidemux sucks for editing
[04:01] <hallowicked> always throws my stuff off
[04:01] <hallowicked> even when i copy copy
[04:02] <Arthur_D> it was a disappointment yeah. Especially since it seemed to be very good for its purpose in all other aspects
[04:02] <hallowicked> what type of videos do u encode?
[04:04] <Arthur_D> well, for the time being, I'm trying to author a DVD, so I go for as lossless as possible since the DVD authoring program often needs to reencode at the end
[04:05] <hallowicked> just a normal dvd?
[04:05] <hallowicked> i do live tv and dvds
[04:06] <piercedwater> I switched from HandBrakeCLI, where I was getting 100+ fps and now when I use ffmpeg I am only getting ~15fps. I assume it is because it is not using all of my cores. My command is 'ffmpeg -threads 4 -i <path> <output>.mp4'
[04:06] <piercedwater> Would be greatful for some help
[04:06] <hallowicked> put threads at the end
[04:07] <hallowicked> ffmpeg -i infile  options -threads  outfile
[04:07] <hallowicked> and checkyour task manager u should be using 100% pc  or close to it
[04:07] <piercedwater> didn't make a dufferebce
[04:07] <piercedwater> difference
[04:07] <hallowicked> if u do -threads 0
[04:07] <hallowicked> try -threads 0
[04:08] <piercedwater> still slow
[04:08] <piercedwater> im at 50% cpu usage
[04:08] <hallowicked> hmm
[04:08] <piercedwater> when it's running
[04:08] <piercedwater> im on freebsd 9
[04:08] <hallowicked> could u pastebin your output  ill take a look see if i notice nething
[04:08] <piercedwater> sure
[04:08] <hallowicked> kk ill be here when your ready
[04:09] <piercedwater> http://dpaste.com/691261/
[04:10] <hallowicked> line 1
[04:10] <hallowicked> -threads 0
[04:10] <hallowicked> put before output file
[04:11] <hallowicked> ffmpeg -i infile.mkv  -threads 0  outfile.mp4
[04:11] <hallowicked> try that
[04:11] <piercedwater> im at about 20 fps
[04:12] <hallowicked> ohh
[04:12] <hallowicked> fps was yoru question
[04:12] <hallowicked> im sorry i misread
[04:12] <piercedwater> np
[04:12] <hallowicked> i belive to set fps is
[04:12] <hallowicked> -r
[04:12] <piercedwater> no
[04:12] <piercedwater> i mean
[04:12] <piercedwater> wait
[04:12] <piercedwater> am i being dumb
[04:12] <hallowicked> i dunno i may be
[04:12] <hallowicked> lol
[04:13] <hallowicked> im lost now
[04:13] <piercedwater> fps during conversion states how many frames it is converting per second, right
[04:13] <hallowicked> i dont think so
[04:13] <hallowicked> i could be wrong
[04:13] <hallowicked> whats the orginal files fps
[04:15] <piercedwater> i believe fps has to do with how fast it is converting. b/c i was getting 100+ in handbrakecli
[06:50] <nutron> Oh hello!
[06:52] <nutron> Noob, but I saw an option to convert from flac to mp3 with the -ab option to set the bitrate, I cannot find that option in the man page.  What is the correct option to set the converted bitrate?  I have this so far: ffmpeg -v quiet -i file.flac file.mp3.  How can I ask for 192kbps?
[06:56] <grepper> nutron: I think it is changed to -b:a now.  Search for -b:a in the manpage
[06:57] <grepper> -b:a = audio, -b:v = video
[06:58] <nutron> grepper: ahh thanks
[07:00] <grepper> np
[14:33] <undercash> hello, i m trying to stream on ubuntu using vlc, and i would like to use ffmpeg as video encoder.
[14:34] <undercash> ffmpeg works fine while encoding videos but i guess error message saying my ffmpeg is crippled
[14:34] <undercash> and vlc isn't able to use it
[14:34] <undercash>  avcodec encoder error: cannot find encoder H264 - MPEG-4 AVC (part 10)
[14:34] <undercash> *** Your FFMPEG installation is crippled.   ***
[14:34] <undercash> *** Please check with your FFMPEG packager. ***
[14:35] <undercash> ffmpeg is compiled with x264..
[14:36] <undercash>  http://pastebin.com/f0jd94WC  my ffmpeg version
[15:04] <undercash> ZzzZzz
[15:04] <undercash> ;)
[19:25] <Bombo> i'm trying to mux a video.mp4 and an audio.mp3 stream together with ffmpeg -i video.mp4 -i audio.mp3 -vcodec copy -acodec copy muxed.mp4, it works for ~1h long streams but now i have two ~3h long ones that both give me an error "av_interleaved_write_frame(): Invalid argument[mp4 @ 0225A020] Application provided invalid, non monotonically increasing dts to muxer in stream 0: -7200 >= -7200"
[19:28] <yaomtc> Are there any free tools to strip FairPlay from iTunes videos? I can't find any.
[19:40] <Guest49658> Bombo, try using one of the -async options
[19:52] <Bombo> Mavrik: -async 0 1 give the same error
[19:56] <danonura> help!
[20:05] <undercash> hello, i m trying to stream on ubuntu using vlc, and i would like to use ffmpeg as video encoder.
[20:05] <undercash> ffmpeg works fine while encoding videos but i guess error message saying my ffmpeg is crippled
[20:05] <undercash> and vlc isn't able to use it
[20:05] <undercash> ffmpeg is compiled with x264..
[20:06] <undercash> what is wrong?
[20:10] <Mavrik> *shrug*
[20:10] <Mavrik> undercash, you should probably ask VLC devs what do they expect in the ffmpeg build they're using
[20:10] <Mavrik> or your library devb
[20:10] <Mavrik> it's hard to know what a 3rd party software means by "crippled ffmpeg"
[20:11] <undercash> no idea, they just say it has nothing to do with vlc ;)
[20:11] <undercash> and you say the same ;)
[20:11] <Mavrik> undercash, well... we can help if you can find out what's missing
[20:11] <Mavrik> "FFmpeg is crippled" doesn't say much :P
[20:11] <undercash> avcodec encoder error: cannot find encoder H264 - MPEG-4 AVC (part 10)
[20:11] <undercash> *** Your FFMPEG installation is crippled.   ***
[20:11] <undercash> *** Please check with your FFMPEG packager. ***
[20:11] <Mavrik> mhm
[20:11] <undercash> *** This is NOT a VLC media player issue.   ***
[20:11] <undercash> i know
[20:11] <Mavrik> I see.
[20:11] <Mavrik> undercash, that could just be a version mismatch
[20:11] <Mavrik> which ffmpeg do you have?
[20:12] <sacarasc> undercash: There's a guide in the topic for compiling your own ffmpeg on Ubuntu. And that one won't be crippled.
[20:12] <undercash> http://pastebin.com/SxijajxS
[20:12] <undercash> it s not crippled
[20:13] <undercash> i use it for video encoding
[20:13] <undercash> no problem
[20:13] <undercash> but when i specify  " venc=ffmpeg{blabla} in the vlc transcoding line  it returns this error message
[20:16] <Mavrik> hmm
[20:42] <maujhsn> I have an mplayer install issue...."Help" http://pastebin.com/E5y7yQ63
[20:43] <Mavrik> Your repositories/repository configurations are broken. That's not an ffmpeg issue.
[20:44] <maujhsn> mavrik...OK
[20:46] <maujhsn> Mavrik  Can you solve this issue? http://pastebin.com/8GhUXipq
[20:48] <Mavrik> maujhsn, yeah, your ffmpeg is really old and doesn't have libx264 compiled in
[20:49] <Mavrik> that's why it says "can't find encoder libx264"
[20:49] <Mavrik> maujhsn, if you're on ubuntu, follow this guide:
[20:49] <Mavrik> http://bit.ly/3xSE5
[20:57] <maujhsn> Mavrik "That old post still works?
[21:11] <maujhsn> Mavrik "How do you know if the conventions to that old post still work?"
[21:18] <maujhsn> Can anybody solve this issue? "http://pastebin.com/8GhUXipq" I am skeptical about Mavrik's take on this issue!
[21:19] <apoc> does ffmpeg somehow support f4v / f4a ? and is it possible to live transcode h264 into an flv container?
[21:21] <maujhsn> apoc You might find the answer to your question in /usr/doc/ffmpeg
[21:22] <apoc> not a word about f4a/v
[21:22] <apoc> but that doesn't mean much, the documentation sucks
[21:23] <maujhsn> apoc OK
[21:27] <maujhsn> Here are my installed packages for libx264...now how do I compile it? "http://pastebin.com/1ppg9JmB".
[21:35] <Mavrik> maujhsn, there's nothing old about it. You have all the instructions you need right where I pointed you.
[21:35] <Mavrik> Your "scepticism" doesn't change a thing.
[21:35] <Mavrik> apoc, hmm
[21:35] <Mavrik> apoc, flv is supported for demuxing and muxing
[21:36] <maujhsn> Mavrik...I know I have tried your patience...Please accept my apology..OK?
[21:36] <maujhsn> I will give it a shot!
[22:03] <undercash> One of the most important parts of the preparation for compiling vlc-git is preparing a recent version of libavcodec for vlc usage. The following accomplishes this with a local, not system installation of FFmpeg and is again a single command:
[22:04] <undercash> so what i should have 2 ffmpeg on my system
[22:04] <undercash> doesnt seem recommended
[22:06] <maujhsn> Mavrik So far it is download is OK accept this: "http://pastebin.com/FAHDQEKF" any suggestions?
[22:06] <maujhsn> Mavrik Seven steps were completed.
[22:08] <Mavrik> undercash, that depends... because large pieces of Ubuntu are dependant on packaged libav* libraries, local installation is a better choice
[22:08] <Mavrik> (even though, I don't have problems running the new version)
[22:09] <undercash> i have ffmpeg installed using the usual ffmpeg topic by fakeman
[22:09] <undercash> i guess that one is the system one
[22:09] <undercash> won't it create some conflict if i install this local version for vlc?
[22:09] <Mavrik> undercash, yeah, that overwrites the system version
[22:10] <Mavrik> undercash, um, basically, you're not supposed to do checkinstall
[22:10] <Mavrik> but you'll have to pass "--prefix=<install folder>" for configure
[22:10] <Mavrik> and run VLC with LD_LIBRARY_PATH that shows to the custom built libraries
[22:10] <undercash> he described this in the second code box http://ubuntuforums.org/showthread.php?t=1398119
[22:11] <undercash> third
[22:11] <maujhsn> Mavrik  Do I just leave things alone now? Or do I execute step number 9? "Updating FFmpeg and x264".
[22:12] <Mavrik> maujhsn, you didn't follow all the instructions and your checkinstall fails
[22:12] <Mavrik> why aren't you reading your output?
[22:14] <maujhsn> Mavrik Do I need to start from the beginning again?
[22:17] <undercash> can't be wrong
[22:20] <maujhsn> Mavrik Check this out: http://pastebin.com/FgNaiKrp
[22:21] <Mavrik> "ERROR: libmp3lame >= 3.98.3 not found"
[22:21] <Mavrik> Read. Error. Messages.
[22:24] <maujhsn> Mavrik "How do I pull up the log file?
[22:31] <maujhsn> Mavrik Never mind I found it...I will send it to you!
[22:38] <maujhsn> Mavrik Couldn't find package libmp3lame to install
[23:23] <brontosaurusrex> hi, any known recent breakga
[23:23] <brontosaurusrex> in experimental aac encoder?
[23:23] <brontosaurusrex> breakage* even
[23:25] <iive> brontosaurusrex: can you bisect it?
[23:26] <brontosaurusrex> iive, http://pastebin.com/05fpDXnP
[23:29] <brontosaurusrex> from what i follow the dev mailing list, there appears to be some cosmetic changes regarding some arc errors only….
[23:29] <brontosaurusrex> aac*
[23:29] <iive> i'm totally clueless about muxers and aac/audio codecs
[23:29] <iive> btw did you try the advice that was printed? :
[23:29] <PovAddict> how do I speedup a video using ffmpeg?
[23:29] <iive> -absf aac_adtstoasc
[23:30] <brontosaurusrex> iive, yes, that advice brings up some other error then
[23:30] <PovAddict> I thought "-r 250 -i input.mp4 -r 25 output.mp4" would grab one frame every 10, thus giving me a 10x speed video
[23:30] <PovAddict> but it doesn't let me give an input -r
[00:00] --- Sun Jan 22 2012

More information about the Ffmpeg-devel-irc mailing list