[Ffmpeg-devel-irc] ffmpeg.log.20120125

burek burek021 at gmail.com
Thu Jan 26 02:05:01 CET 2012

[01:51] <keyvan> If i am bundling a compiled ffmpeg (with x264) binary with my python program, does my program have to be GPL?
[01:52] <JEEB> are you linking it or only invoking it via command line?
[01:52] <JEEB> *linking to it
[01:53] <JEEB> or well, more like, are you using the C interfaces of the library or just calling out the command line apps?
[01:57] <keyvan> JEEB: invoking from command line
[01:58] <JEEB> I would say that in that case you're not really linking to them, but only using the tools. Do release the source code for the applications used, tho. Although IANAL and haven't read into the intricasies of GPL that much.
[01:59] <JEEB> although even if you were linking against it, the actual application doesn't have to be under GPL. The source code of the thing used together with GPL'd libraries would be GPL tho, of course. (example: a library can be MIT/BSD, but if you build it with GPL ffmpeg that package becomes GPL)
[02:01] <JEEB> real example: ffmpegsource is either BSD or MIT, but if it becomes linked with a GPL ffmpeg that is a GPL package and all sources need to be released.
[02:05] <keyvan> thanks JEEB
[02:07] <JEEB> just remember that you are distributing GPL software and thus need to release the sources for the GPL parts as well :)
[02:08] <keyvan> we're just compiling from ffmpeg's trunk, do we just need to link to ffmpeg project from our download page and that's sufficient?
[02:19] <Zeranoe> Does anyone know a easy way to disable all encoders other than mpeg-2? Or do I need to disable every other one?
[02:20] <flecha> Good night! How do I add multiple genres tags to my AAC, M4A files? Not necessarily with ffmpeg...
[02:20] <drv> Zeranoe: configure --disable-encoders --enable-encoder=mpeg2video
[02:21] <Zeranoe> drv: Excellent, thank you
[15:24] <cbreak-work> I am writing a program that writes audio and video data into a pipe, for further consumption by other code
[15:24] <cbreak-work> but I have problems with the audio
[15:25] <cbreak-work> the resulting stream has the correct number of image frames, but not enough audio samples
[15:26] <cbreak-work> I am trying to use nut container format
[15:45] <omeone> How to make ffmpeg behave with named pipes as like with normal files?
[15:47] <cbreak-work> what do you mean?
[15:47] <cbreak-work> named pipes aren't seekable
[15:50] <omeone> is that a problem for ffmpeg?
[15:54] <omeone> the video looks corrupted if it came from pipe...
[15:54] <omeone> they're smaller exactly at 7072 bytes...
[15:55] <omeone> and ffmpeg writes: muxing overhead -100.000000%
[15:55] <omeone> Lsize=       0kB
[15:56] <omeone> oh, is there libav irc channel?
[16:01] <cbreak-work> it depends on what format you want to pipe
[16:01] <cbreak-work> someone told me that nut container is ok for it, but I am having problems with audio.
[16:01] <cbreak-work> It worked a few days ago, and I have no idea what I did to make it stop working :/
[16:01] <omeone> I don't need an audio
[16:02] <omeone> how to use that container?
[16:05] <cbreak-work> like any other
[16:26] <omeone> WOW with this 'nut' container videos have the same size!
[16:26] <omeone> Can they be opened in Windows?
[16:59] <omeone> which containers can I use to output to named pipe?
[17:00] <cbreak-work> just got mine working again
[17:00] <cbreak-work> nut works nice, even with audio now :)
[17:00] <cbreak-work> stupid ffmpeg... somehow magically fixed my problem with repeated make clean && make disclean && ./configure && make && make install
[17:00] <cbreak-work> ah well :)
[17:02] <omeone> I used nut but it haven't (or hadn't - correct me please) opened in Windows...
[17:03] <burek> omeone, i used mpeg-ts
[17:03] <burek> since it's optimized for streaming
[17:03] <burek> i figured it would do well with pipes too
[17:03] <cbreak-work> omeone: mplayer and ffmpeg work on windows too
[17:05] <omeone> the next problem - I can't use ffmpeg directly... I'm using OpenCV and one thing I'm allowed to select is "4-character code of codec used to compress the frames. For example, CV_FOURCC('P','I','M,'1') is a MPEG-1 codec, CV_FOURCC('M','J','P','G') "
[17:07] <burek> +google wikipedia fourcc
[17:07] Action: burek slaps fflogger
[17:07] <burek> oh :) good boy :)
[17:08] <omeone> but I need to choose a container too, isn't it?
[17:09] <burek> well we are not so deep into that problem as you are, you need to explain stuff a little more
[17:09] <burek> why do you need a container?
[17:09] <cbreak-work> raw video streams are usually not well defined
[17:09] <cbreak-work> well, sometimes hey aren't
[17:10] <cbreak-work> (because they do not contain information about what format they are themselves)
[17:10] <cbreak-work> sometimes :)
[17:10] <burek> but if you are creating and dealing with that stream, you are good to go, no? :)
[17:10] <cbreak-work> I think h.264 raw works though. and it's a good codec.
[18:36] <boo> Hi! I'm still experiencing problems, while converting data from dvb-t MPEG-4 stick and sending it to rtmp. It's probably something with the options/codecs that are called with ffmpeg. Interesting is the fact that it quits usually at 5th second, usually - 5:20sec +/- several miliseconds.
[18:36] <boo> Here's a fragment of the dvb-t stream written dirrectly with 'cat' - http://beberry.lv/up/u/test2 and here's the ffmpeg output http://pastebin.com/16m6Tx0b can someone please help? I'm stuck with this and it's really frustrating.
[18:37] <boo> The command that I ran with is  ffmpeg -y -isync -vcodec h264 -pix_fmt yuv420p -s 720x576 -i /dev/dvb/adapter0/dvr0 -vcodec libx264 -acodec libfaac -ac 2 -ar 44100 -ab 128k -s 100x100 -r 20 -f flv rtmp://blaablalba/live
[18:59] <boo> anyone, who could help?
[19:20] <Freakshow> which version of ffmpeg are you using?
[19:20] <Freakshow> I don't see it in the pastebin
[19:27] <boo> freakshow, 0.7.8 if I'm correct
[19:28] <boo> Freakshow, one guy from gentoo channel recomended me to try libav, but I don't know.. I still want to get that ffmpeg up and running
[19:31] <burek> boo, that's probably h264 packed into mpeg-ts
[19:31] <burek> and pay attention to this line [mpegts @ 0x98dce60] max_analyze_duration 5000000 reached at 5016000
[19:32] <burek> that means after 5 seconds, ffmpeg couldn't get a valid data to start with
[19:32] <burek> which can indicate that the input stream is somehow malformed
[19:33] <boo> burek, In the beginning I assumed that 5000000 is something to do with the ffmpeg config
[19:34] <boo> burek, what could be the cause of that? bad reception for dvb-t antena? the reception is ok..
[19:34] <burek> try with: ffmpeg -analyzeduration 15000000 ...
[19:35] <burek> I had the same problem
[19:35] <burek> which was that ip camera, that produced h264/ts was somehow
[19:35] <burek> sending moov atom (or any other sync packet) every 10 seconds
[19:35] <boo> burek, I'm currently re-emerging ffmpeg,
[19:36] <burek> so, ffmpeg mostly failed, but sometimes succeeded, depending on the moment it was started
[19:36] <fweeb> I'm trying to encode to qtrle with the API (adding qtrle support to Blender). It encodes, but the resulting frames are not at all like the originals (http://pasteall.org/pic/show.php?id=25068). Anyone have an idea of what I'm not doing correctly?
[19:36] <burek> don't emerge it, compile it
[19:36] <burek> it takes 10 minutes
[19:36] <boo> burek, yes I was thinking that there's something in that stream in each 5 seconds..
[19:37] <boo> burek,  how to do that? I'm now emeriging , but it fails http://pastebin.com/vMWRatNW
[19:38] <boo> fweeb, sorry can't help.
[19:38] <burek> boo, just do: git clone git://source.ffmpeg.org/ffmpeg.git   then cd ffmpeg   and then   ./configure --enable-libx264
[19:38] <fweeb> boo: bummer. Thanks for reading all the same
[19:38] <burek> if you want to compile libx264 too (recommended): http://pastebin.com/LhRkXhzZ
[19:41] <boo> burek, do you know why it's not emerging? still want to do the emerge better than downloading git..
[19:42] <burek> i dont use emerge, sorry
[19:42] <burek> also, using prebuilt package
[19:42] <burek> will always bring you trouble
[19:42] <burek> sooner or later
[19:42] <burek> its much better to use git
[19:42] <burek> and from time to time to do: git pull
[19:43] <burek> to update code and do make clean && make && make install again
[19:43] <burek> that way you keep away from bugs :)
[19:43] <boo> why trouble? ++ should I add ffmpeg -analyzeduration 15000000 to other options?
[19:43] <burek> because if you work with multimedia, you always need the latest codecs and stuff
[19:43] <boo> ok, if I use git is ffmpeg installed in the same place where I download it, or I can delete it later?
[19:43] <burek> packages are usually stall
[19:44] <boo> burek, ok, didn't knew what's git :>
[19:44] <burek> git is just a repository
[19:44] <burek> the idea is that you should use the latest version of the code :)
[19:44] <burek> just delete unemerge what you installed
[19:44] <burek> compile libx264
[19:44] <burek> compile ffmpeg
[19:44] <burek> and thats it
[19:47] <fweeb> boo: It looks like the ffmpeg page you're trying to emerge is requring a use flag of -x264 (meaning, x264 support won't be included). To get that package to emerge properly, you'll have to either set the use flag as an environement variable immediately prior to emerging or change your global use flags
[19:48] <fweeb> s/page/package
[19:49] <boo> fweeb I had x264 as an useflag
[19:49] <fweeb> boo: right... you have +x264... it's asking for -x264
[19:49] <fweeb> unless I'm reading it backwards
[19:50] <boo> fweeb, ok, didn't knwe that there's an difference
[19:50] <boo> Curently doing the git thing
[19:51] <fweeb> the + indicates that the package is used whereas the - indicates that it's not to be used (unless something's changed with portage since I last used gentoo)
[19:52] <burek> well he needs x264
[19:52] <boo> fweeb, I think I had it without both, dunno
[19:52] <boo> burek, first of all i need to do git://source.ffmpeg.org/ffmpeg.git   then cd ffmpeg   and then   ./configure --enable-libx264  and then the libx264, or there's no difference?
[19:53] <burek> first libx264
[19:53] <burek> because you will link it against ffmpeg
[19:53] <burek> to build the final binary
[19:53] <burek> which will support h264
[19:54] <pasteeater> you'll probably want --enable-static for x264 ./configure
[19:54] <boo> fweeb i had x264 as a use flag :) without + or -
[19:55] <fweeb> boo: without + or - implies +, IIRC
[19:56] <boo> fweeb ?
[19:57] <fweeb> Sorry... too many symbols. If you have x264 in your use flags without a plus or minus, then you're implying a plus, if I recall correctly
[19:57] <boo> burek ok, did that thing which you uploaded at pastebin, now doinf ffmpeg
[19:58] <boo> fweeb, yes it's true,  :) As I said, I had it :P
[19:59] <burek> just a sec
[20:00] <burek> ok, I'm here
[20:00] <burek> boo, good good :)
[20:00] <burek> just do it :)
[20:00] <boo> burek http://pastebin.com/MC3nWnH3
[20:01] <burek> just add --enable-gpl
[20:01] <boo> burek, did everything said in here http://pastebin.com/LhRkXhzZ then git clone git://source.ffmpeg.org/ffmpeg.git   then cd ffmpeg   and then   ./configure --enable-libx264
[20:01] <boo> ok
[20:01] <burek> ./configure --enable-libx264 --enable-gpl
[20:04] <boo> burek, done.
[20:04] <burek> great
[20:04] <burek> now
[20:04] <burek> hash -r
[20:04] <burek> ldconfig
[20:05] <burek> and ffmpeg -version
[20:05] <burek> it should say N-37145-g5cb57a1
[20:05] <boo>  ffmpeg -version -bash: ffmpeg: command not found
[20:05] <burek> did you do make and make install
[20:06] <boo> No, that was what I thinking about :)
[20:06] <burek> :D
[20:06] <boo> I thought that it's wierd :D :D
[20:06] <burek> ^^
[20:25] <boo> loong loong make & install process
[20:26] <burek> what line did it get too so far?
[20:26] <burek> to*
[20:27] <relaxed> ffmpeg was removed, try avconv
[20:27] <burek> removed from where
[20:28] <relaxed> teh source I believe
[20:28] <boo> burek  CC      libavcodec/mpeg4videodec.o
[20:28] <burek> hm.. your machine is some old one, is it?
[20:29] <boo> burek, yeah, like 7 yrs
[20:29] <burek> well :) it's at the middle :)
[20:31] <boo> burek, hate that it takes so long :( the CPU can't manage that load. 100% and lavg 1,0  eh, old intel celeron
[20:32] <burek> that's why we need static ffmpeg binary :)
[20:32] <burek> but I just can't build it :S
[20:33] <boo> burek, so after installation I can delete both - ffmpeg and x264 folders?
[20:33] <burek> well, if you really need to
[20:33] <burek> if not, don't
[20:34] <burek> because you won't be able to do make uninstall later, when you decide to uninstall it (for some reason)
[20:35] <boo> that's wierd.... I know it's not right, but I'm downloading it in the root folder
[20:35] <burek> :D
[20:40] <pasteeater> relaxed: s/removed/removed from libav/
[20:41] <pasteeater> FFmpeg will probably remove avconv soon unless anyone wants to maintain it
[20:42] <relaxed> pasteeater: ok, this confused me --> http://git.videolan.org/?p=ffmpeg.git;a=commit;h=0fec2cb15cc6ff1fcc724c774ec36abadcb7b6ad
[20:42] <pasteeater> yeah, the merged commit logs from libav can be confusing.
[20:43] <boo> burek, the last lines - http://pastebin.com/nx9C7Wfa
[20:43] <relaxed> burek: I'm not sure that all libs can be added to the binary.
[20:43] <relaxed> like librtmp for example
[20:44] <burek> boo, it failed at the final step :(
[20:44] <pasteeater> boo: you probably have multiple installations of x264 which may include x264-dev package depending on your distro
[20:44] <boo> aaaah
[20:44] <burek> delete all and use emerge..
[20:45] <boo> burek, hm, delte both folders and emerge ffmpeg?
[20:46] <burek> unless you want to recompile it again
[20:47] <boo> burek, already deleted it :( Anyways, why the emerge isn't good enough? It still compiles on the machine, don't they update it so often?
[20:48] <burek> if your machine is too slow for compilations, why don't you use ubuntu/debian
[20:48] <burek> with precompiled packages
[20:49] <boo> burek, don't compile so often, like gentoo better, needs less resources
[21:28] <jermy> does ffmpeg gain much from access to a GPU?
[21:30] <hi117> not really, encoding is a CPU task while decoding is GPU/CPU IIRC
[21:30] <boo> burek, I'm going to kill myself. again at the very end - http://pastebin.com/YbVwi17t  and http://pastebin.com/UNKqz1XS
[21:31] <Svedrin> hi folks. I'm currently building a little media player using libavcodec/libavformat, and I have two questions. :)
[21:31] <Svedrin> does avcodec_decode_audio4 always return its data in s16le?
[21:32] <jermy> ok. So a decode/encode cycle (of 1080i content) should get some performance improvements on decode, assuming libva is available?
[21:32] <Svedrin> and when trying to decode different files, mp3 and flac seem to work, but for a vorbis file, avcodec_decode_audio4 doesn't update the got_frame int. what might be the cause?
[21:35] <Svedrin> my code is here: http://pastebin.com/VwycD3PF
[22:49] <boo> buerk, ffmpeg is set up. now what do Ihave to do?
[22:53] <relaxed> boo: what are you trying to do?
[22:54] <boo> relaxed I'm experiencing problems, while converting data from dvb-t MPEG-4 stick and sending it to rtmp. It's probably something with the options/codecs that are called with ffmpeg. Interesting is the fact that it quits usually at 5th second, usually - 5:20sec +/- several miliseconds.
[22:54] <boo> Here's a fragment of the dvb-t stream written dirrectly with 'cat' - http://beberry.lv/up/u/test2 and here's the ffmpeg output http://pastebin.com/16m6Tx0b can someone please help? I'm stuck with this and it's really frustrating.
[22:54] <boo> The command for ffmpeg is ffmpeg -y -isync -vcodec h264 -pix_fmt yuv420p -s 720x576 -i /dev/dvb/adapter0/dvr0 -vcodec libx264 -acodec libfaac -ac 2 -ar 44100 -ab 128k -s 100x100 -r 20 -f flv rtmp://tooth.beberry.lv/oflaDemo/streams/live
[22:55] <boo> burek advised to do something related with ffmpeg -analyzeduration 15000000   just emerged the unstable version 9.1 will try rhat
[22:56] <relaxed> why are you scaling 720x576 to 100x100?
[22:57] <boo> relaxed, testing purpouses, thought that it might take less memory cpu + less to download
[22:59] <relaxed> so it's a problem with decoding?
[22:59] <boo> relaxed, probably
[23:00] <relaxed> pastebin the output of ffmpeg -i /dev/dvb/adapter0/dvr0
[23:03] <boo> relaxed, looks like frozen http://pastebin.com/7X8GTXaY
[23:06] <boo> relaxed, lol, I forgot to turn on the dvb-t stick
[23:07] <boo> relaxed http://pastebin.com/gqiwkCbd
[23:13] <boo> it says now - Option video_size not found.
[23:18] <boo> relaxed, still here?
[23:18] <relaxed> can you copy the streams? ffmpeg -i /dev/dvb/adapter0/dvr0 -c copy -f mpegts out.mpeg
[23:19] <fweeb> anyone here well-versed in FFMPEG's C API?
[23:22] <boo> relaxed http://beberry.lv/up/u/out.mpeg  here's the output http://pastebin.com/ugqawm69  this is a ~6 sec recording during the day using 'cat' http://beberry.lv/up/u/test2
[23:28] <relaxed> boo: test2 encodes fine here. there's some grey at the beginning though
[23:28] <boo> relaxed test 2 is made by cat mydvbdevice > test2
[23:29] <boo> could be first seconds when ffmpeg connects to stream
[23:30] <boo> relaxed http://pastebin.com/c1eNwuXR with ffmpeg -i /dev/dvb/adapter0/dvr0 -vcodec libx264 -acodec libfaac -ac 2 -ar 44100 -ab 128k -r 20 -f flv rtmp://tooth.beberry.lv/oflaDemo/streams/live
[23:30] <relaxed> I still don't understand what your problem is.
[23:30] <boo> see pastebin
[23:31] <relaxed> is that log from the new ffmpeg you just built?
[23:31] <boo> relaxed, ffmpeg decodes and then just stops decoding.
[23:31] <boo> No it's output when decoding now the stream. Output of ffmpeg -i /dev/dvb/adapter0/dvr0 -vcodec libx264 -acodec libfaac -ac 2 -ar 44100 -ab 128k -r 20 -f flv rtmp://tooth.beberry.lv/oflaDemo/streams/live
[23:33] <boo> relaxed, as I said, it usually fails @ time=00:00:05.2 +/- 14ms
[23:33] <boo> relaxed, so there's something in that test2 @ 00:00:05.2 what makes ffmpeg crash
[23:34] <relaxed> I'm able to encode test2 to "Duration: 00:00:13.16"
[23:35] <relaxed> pastebin the following command and all output, ffmpeg -i test2 -vf yadif -q:v 2 -q:a 0 output.avi
[23:35] <boo> relaxed, mmn wierd. Argh. with the same parameters?
[23:37] <boo> relaxed, yes everything in this case went ok
[23:40] <boo> relaxed, even with the same parameters, replacing dvb-t stick with test2 is ok - ffmpeg -i ~/test2 -vcodec libx264 -acodec libfaac -ac 2 -ar 44100 -ab 64k -r 23 -f flv rtmp://tooth.beberry.lv/oflaDemo/streams/live didn't crash..
[23:43] <relaxed> maybe -vsync 1 before the input would help, I don't know
[23:46] <boo> relaxed, if I do cat mydvb > test and at the same time run ffmpeg decoding test then it doesn't crash..
[23:50] <boo> and again it fails ar 5.20 sec :@ :@
[23:52] <relaxed> sorry, I'm out of ideas
[23:52] <boo> eh, sad.. It's something related with that dvb-t stick
[00:00] --- Thu Jan 26 2012

More information about the Ffmpeg-devel-irc mailing list