[Ffmpeg-devel-irc] ffmpeg-devel.log.20120124

burek burek021 at gmail.com
Wed Jan 25 02:05:02 CET 2012

[01:02] <Compn> ubitux : the yadif uses a seperate thread than ffmpeg's thread right ?
[01:02] <Compn> is that all ok if you got 2 threads for decode, 2 threads for yadif, 2 threads for encode ?
[01:04] <ubitux> i guess, but i'm wondering what's going to happen if you -threads auto (which is likely to be used by the user)
[01:04] <ubitux> -threads auto will make use of all your cpus afaik
[01:05] <ubitux> then maybe threading more in yadif may just slower things
[01:05] <Compn> guess you'll have to bench
[01:05] <ubitux> but as michaelni said, someone should benchmark
[01:05] <ubitux> no i think i will just go to sleep ;)
[01:21] <pasteeater> '-threads auto' was the old libx264 only '-threads 0', IIRC
[01:52] <CIA-31> ffmpeg: 03Paul B Mahol 07master * rf7a9b1deee 10ffmpeg/libavformat/cafdec.c: 
[01:52] <CIA-31> ffmpeg: cafdec: fix regression introduced in c7579ad8e84c5
[01:52] <CIA-31> ffmpeg: Signed-off-by: Paul B Mahol <onemda at gmail.com>
[01:52] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[01:53] <CIA-31> ffmpeg: 03Maksym Veremeyenko 07master * r2aadff2e44 10ffmpeg/libavformat/movenc.c: 
[01:53] <CIA-31> ffmpeg: limit chunk size to 1GB
[01:53] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[01:53] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * rf58d670002 10ffmpeg/ (14 files in 5 dirs): 
[01:53] <CIA-31> ffmpeg: movenc: Decrease default chunk merge limit to 1mb.
[01:53] <CIA-31> ffmpeg: This reduces the delay when opening the video with quicktime.
[01:53] <CIA-31> ffmpeg: Idea-by: Maksym Veremeyenko <verem at m1stereo.tv>
[01:53] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[03:04] <CIA-31> ffmpeg: 03Justin Ruggles 07master * re924a4ba71 10ffmpeg/libavformat/ (Makefile westwood_aud.c westwood.c): 
[03:04] <CIA-31> ffmpeg: westwood: split the AUD and VQA demuxers into separate files.
[03:04] <CIA-31> ffmpeg: They have no code in common.
[03:04] <CIA-31> ffmpeg: 03Janne Grunau 07master * r50a3f9a4bd 10ffmpeg/libavformat/mxfdec.c: mxfdec: fix memleak on mxf_read_close()
[03:04] <CIA-31> ffmpeg: 03Paul B Mahol 07master * r27ed027bcd 10ffmpeg/ (10 files in 4 dirs): 
[03:04] <CIA-31> ffmpeg: XWD encoder and decoder
[03:04] <CIA-31> ffmpeg: Signed-off-by: Kostya Shishkov <kostya.shishkov at gmail.com>
[03:05] <CIA-31> ffmpeg: 03Nathan Caldwell 07master * r17ae608127 10ffmpeg/libavcodec/aacenc.c: 
[03:05] <CIA-31> ffmpeg: aacenc: aac_encode_init() cleanup
[03:05] <CIA-31> ffmpeg: Macroify sanity checks and check return values of allocs and other functions.
[03:05] <CIA-31> ffmpeg: Signed-off-by: Alex Converse <alex.converse at gmail.com>
[03:05] <CIA-31> ffmpeg: 03Nathan Caldwell 07master * r5310704190 10ffmpeg/libavcodec/aacenc.c: 
[03:05] <CIA-31> ffmpeg: aacenc: cosmetics: move init() and end() to the bottom of the file.
[03:05] <CIA-31> ffmpeg: Signed-off-by: Alex Converse <alex.converse at gmail.com>
[03:05] <CIA-31> ffmpeg: 03Nathan Caldwell 07master * r207bf44d16 10ffmpeg/libavcodec/aaccoder.c: 
[03:05] <CIA-31> ffmpeg: aacenc: cosmetics, replace 'rd' with 'bits' in codebook_trellis_rate to make it more clear what is being calculated.
[03:05] <CIA-31> ffmpeg: Signed-off-by: Alex Converse <alex.converse at gmail.com>
[03:05] <CIA-31> ffmpeg: 03Nathan Caldwell 07master * r843cd4a3ed 10ffmpeg/libavcodec/aacpsy.c: 
[03:05] <CIA-31> ffmpeg: aacpsy: cosmetics, change a FIXME to a NOTE about subshort comparisons
[03:05] <CIA-31> ffmpeg: Also fix a typo.
[03:05] <CIA-31> ffmpeg: Signed-off-by: Alex Converse <alex.converse at gmail.com>
[03:05] <CIA-31> ffmpeg: 03Nathan Caldwell 07master * r80d44277e6 10ffmpeg/libavcodec/ (aaccoder.c aacenc.c aacenc.h): 
[03:05] <CIA-31> ffmpeg: aacenc: Move Q^3/4 calculation to it's own table
[03:05] <CIA-31> ffmpeg: This should be moved to tablegen at some point.
[03:05] <CIA-31> ffmpeg: Signed-off-by: Alex Converse <alex.converse at gmail.com>
[03:05] <CIA-31> ffmpeg: 03Nathan Caldwell 07master * r025ccf1f8b 10ffmpeg/libavcodec/ (aacenc.c aacenc.h aacpsy.c psymodel.c psymodel.h): 
[03:05] <CIA-31> ffmpeg: aacenc: Request normalized float samples instead of converting s16 samples to float.
[03:05] <CIA-31> ffmpeg: Signed-off-by: Alex Converse <alex.converse at gmail.com>
[03:05] <CIA-31> ffmpeg: 03Nathan Caldwell 07master * r04af2efaae 10ffmpeg/libavcodec/ (aacenc.c aacenc.h): 
[03:05] <CIA-31> ffmpeg: aacenc: Store channel count in AACEncContext.
[03:05] <CIA-31> ffmpeg: Signed-off-by: Alex Converse <alex.converse at gmail.com>
[03:05] <CIA-31> (31 lines omitted)
[03:46] <burek> :)
[03:47] <burek> if anyone has ever compiled/built ffmpeg as one big fat GPL binary, could you please let me know in PM what switches have you used? :) thanks :)
[04:03] <Compn> --enable-gpl --enable-static ? :P
[04:12] Action: michaelni suspects thats not enough
[04:12] <michaelni> probably more building twice and using magic to combine
[04:13] <michaelni> but maybe i misuderstood what was meant by fat ;)
[04:15] <Compn> fat = static i'm guessing
[04:15] <Compn> but could have different meaning
[04:15] <Compn> burek: ping
[04:17] <funman> perhaps it's a binary with the name ALL IN CAPS
[04:21] <michaelni> https://en.wikipedia.org/wiki/Fat_binary
[04:29] <Compn> oh those
[04:29] <Compn> only seen those used on mac for x86 and ppc
[04:29] <Compn> which is done differently because its just two binaries in one mac package
[04:29] <Compn> (on osx that is)
[04:41] <funman> Compn: there was a proposal for linux too
[04:42] <funman> one game developer did all the patches for libc / binutils ( / kernel?) and he got pissed off by answers and abandoned the project
[04:44] <Compn> was it a good idea ?
[04:44] <funman> probably yes
[04:44] <Compn> i guess it makes it easier for users
[04:44] <Compn> trying to change libc / binutils and kernel all at the same time sounds like an uphill battle
[04:44] <funman> the goal was games distributon for linux (1 static binary for every arch known to man)
[04:45] <Compn> oooo
[04:45] <funman> but could have worked for debian multiarch too
[04:45] <funman> http://en.wikipedia.org/wiki/Executable_and_Linkable_Format#FatELF:_Universal_Binaries_for_Linux
[04:46] <funman> http://icculus.org/fatelf/
[04:46] <funman> they made a quake2 gpl'd version (or quake 3??)
[04:46] <Compn> oh neverball guy
[04:46] <Compn> awesome
[04:47] <Compn> er nm
[04:47] <Compn> i like neverball, its hosted there :)
[04:48] <funman> neverball? here?
[04:48] <funman> here = on the internet?
[04:48] <funman> i've heard of things hosted on internet yes :)
[04:48] <Compn> there on icculus
[04:48] <Compn> thar be wolves
[04:49] <funman> ok
[06:41] <Compn> michaelni : think it would be a good idea for a news entry talking about resubmitting unapplied patches to ffmpeg?
[06:42] <Compn> it seems like ffmpeg has missed quite a few patches over the years, would be nice to apply some of them :)
[06:42] <Compn> re: dvd support, i had no idea there was a patch
[06:42] <michaelni> yes, please send a patch
[06:43] <michaelni> or pasteit or something
[06:44] <michaelni> i also wasnt aware of that dvd stuff
[09:57] <ubitux> michaelni: i'd like to push the afresample libswr patch, but the outputs change
[09:57] <ubitux> i tried to a 44100Hz music to 8000Hz
[09:58] <ubitux> i can't distinguish the two
[09:58] <ubitux> they both sounds the same to me
[10:02] <ubitux> mmh actually the current version looks broken
[10:11] <ubitux> i have a pretty strange bug with -f lavfi -i amovie=a.mp3,aresample=8000 -t 10; before: output is 0 seconds (a few bytes), after: -t is simply ignored&
[10:44] <CIA-31> ffmpeg: 03Clément BSsch 07master * r66fdbcbbc9 10ffmpeg/libavfilter/af_pan.c: pan: raise correct error when there is no param specified.
[10:44] <CIA-31> ffmpeg: 03Clément BSsch 07master * r6728dd37ac 10ffmpeg/ (4 files in 3 dirs): pan: add channel mapping capability.
[10:44] <CIA-31> ffmpeg: 03Clément BSsch 07master * r94dc4a5046 10ffmpeg/libavfilter/af_pan.c: pan: reindent after remap commit.
[10:44] <CIA-31> ffmpeg: 03Clément BSsch 07master * r66b1b7e5fa 10ffmpeg/libavfilter/af_pan.c: pan: move query_formats() to avoid forward declarations.
[10:44] <CIA-31> ffmpeg: 03Clément BSsch 07master * r9bd44b42a8 10ffmpeg/libavfilter/af_pan.c: pan: drop unecessary includes.
[10:47] <Tjoppen> do I need to do anything special to get gprof to work with say ffprobe?
[10:48] <Tjoppen> I tried --extra-cflags=-pg but that caused a compilation error in x86/mlpdsp.c
[10:48] <Tjoppen> I worked around it, but successfully running either ./ffprobe or ./ffprobe_g results in no gmon.out
[11:37] <burek> Compn, sorry, I fell asleep :)
[11:38] <burek> my goal is to build a static binary
[11:38] <burek> that would allow people to just copy that 1 file onto their machine and run it
[11:38] <burek> similar logic to windows, where people download exe file and just run it, without any problems
[11:40] <av500> --enable-static --disable-shared
[11:45] <burek> thx :)
[11:46] <av500> burek: izvoli
[11:47] <burek> izvoli = yes? = here you are :)
[11:47] <burek> if you meant "you're welcome", than it's "nema na cemu" :) or "don't mention" :)
[11:47] <burek> :beer: :)
[11:48] <av500> burek: yes, please teach me :)
[11:48] <burek> ^^
[11:48] Action: ubitux read "please touch me"
[11:48] <burek> your heart beats next to mine :D viva la sabrina :D
[11:49] <ubitux> Tjoppen: if you are able to do it, i'm interested; also note oprofile might be a better tool
[11:49] <av500> burek: a ne lepa brena?
[11:49] <burek> oh "mile voli disko" :D
[11:49] <burek> \o/
[11:52] <Tjoppen> oprofile seems to take over half the machine or something
[12:02] <burek> openssl is non-free? geez...
[12:03] <burek> libopencore_amrnb is version3 and --enable-version3 is not specified.
[12:03] <burek> will binary stay GPL if I enable this?
[12:06] <burek> ok, I'll try with this and see if it compiles ok: ./configure --enable-static --disable-shared --enable-gpl --enable-runtime-cpudetect --disable-doc --enable-gray --enable-vaapi --enable-vda --enable-vdpau --enable-avisynth --enable-bzlib --enable-frei0r --enable-gnutls --enable-libass --enable-libcelt --enable-libopencv --enable-libcdio --enable-libdc1394 --enable-libdirac --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lam
[12:06] <burek> e --enable-libnut --enable-libopenjpeg --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libstagefright-h264 --enable-libtheora --enable-libutvideo --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-openal --enable-mlib --enable-zlib --enable-pic --enable-sram
[12:16] <burek> hm.. I'm stuck at: ERROR: libcelt not found
[12:16] <burek> and I've installed libcelt-dev
[12:17] <burek> but ffmpeg still says there is such lib
[12:19] <CIA-31> ffmpeg: 03Nicolas George 07master * r0c3577bfd9 10ffmpeg/ (5 files in 2 dirs): lavfi: add avfilter_graph_dump.
[12:19] <CIA-31> ffmpeg: 03Nicolas George 07master * r1fa88f343a 10ffmpeg/ (Changelog libavdevice/lavfi.c): lavd/lavfi: add dumpgraph option.
[12:19] <av500> burek: config.log should tell you
[12:24] <burek> hm i think there's a bug in configure, meaning, the error shold say something like: you have libcelt v X and minimum needed is libcelt v Y
[12:25] <burek> im my case x=0.7.1 and y=0.11 i guess
[12:37] <burek> is libmp3lame considered non-free?
[13:03] <CIA-31> ffmpeg: 03Nicolas George 07master * raf21823ae0 10ffmpeg/libavfilter/Makefile: lavfi: require libswr for af_pan.
[13:15] <Compn> burek : openssl is free, i think you have to just put openssl text everywhere tho. advertisement clause conflicts with gpl :P
[13:15] <Compn> but you can use polarssl or another one i forget now if you dont want to do that
[13:16] <burek> I'm doing this to make one static binary
[13:16] <burek> just like exe
[13:16] <burek> that people can download and run
[13:16] <burek> I'm not making it for myself :)
[13:17] <Compn> yes, i read up
[13:18] <Compn> and afaict with openssl license, thats all you need to do is put 'powered by openssl' in readme, website, about box, etc
[13:18] Action: Compn should reread it
[13:18] <burek> I'm too lazy to modify anything :)
[13:18] <burek> I'll just drop openssl
[13:18] <burek> :)
[13:19] <Compn> yeah its pretty simple
[13:19] <Compn> http://www.openssl.org/source/license.html
[13:19] <Compn> but ok :P
[13:19] <burek> well, I don't want to get anyone angry
[13:20] <burek> if I forget to put the ad somewhere
[13:20] <iive> hi merbanan , nice to see you around.
[13:20] <burek> it's easier for me just to drop it :)
[13:20] <iive> about ssl, i thought that ffmpeg supported gnutls at some point? am I wrong?
[13:21] <burek> i think i compiled it with gnutls
[13:21] <burek> yup, libgnutls-dev
[13:21] <burek> :)
[13:21] <iive> i know it is a little more buggy with certificates... but ...
[13:23] <burek> btw, is utvideo for windows only
[13:24] <burek> cause i can't find any debian package for it
[14:33] <burek> yeah.. i installed libroar-dev which has changed mac address of my eth card, now i can't access the machine anymore.. just great..
[14:53] <michaelni> <ubitux> michaelni: i'd like to push the afresample libswr patch, but the outputs change
[14:53] <michaelni> <ubitux> mmh actually the current version looks broken
[14:54] <michaelni> well, if the current version looks broken (i dont disagree) push the better looking one
[15:33] <CIA-31> ffmpeg: 03Nicolas George 07master * r969ba65ecc 10ffmpeg/configure: 
[15:33] <CIA-31> ffmpeg: libcelt: configure: distinguish not found and too old.
[15:33] <CIA-31> ffmpeg: Fixes ticket #940.
[15:39] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * r20aed9ed4f 10ffmpeg/ffmpeg.c: 
[15:39] <CIA-31> ffmpeg: ffmpeg: Allocate buffers of the size needed by the decoder.
[15:39] <CIA-31> ffmpeg: Fixes bug127
[15:39] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[15:39] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * rb2be1dabb1 10ffmpeg/libavcodec/mpegvideo.c: 
[15:39] <CIA-31> ffmpeg: mpegvideo: Draw edges based on the pictures linesize instead of the contexts.
[15:39] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[15:39] <CIA-31> ffmpeg: 03Tomas Härdin 07master * rece329d629 10ffmpeg/MAINTAINERS: 
[15:39] <CIA-31> ffmpeg: Add myself as mxfdec maintainer
[15:39] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[15:39] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * rbeb19a0444 10ffmpeg/libavcodec/h264.c: 
[15:39] <CIA-31> ffmpeg: h264: Disallow w/h/pixfmt changes for frame threads.
[15:39] <CIA-31> ffmpeg: Previously this was just checked in case of slice threads,
[15:39] <CIA-31> ffmpeg: but frame threads do not support this either currently.
[15:39] <CIA-31> ffmpeg: Making them support this is of course the long term goal
[15:39] <CIA-31> ffmpeg: Fixes bug155
[15:39] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[15:58] <CIA-31> ffmpeg: 03Nicolas George 07master * r9aaa70a845 10ffmpeg/doc/faq.texi: faq: document af_aconvert quirks using lavfi.
[16:03] <CIA-31> ffmpeg: 03Nicolas George 07master * r0c9ddc0fd5 10ffmpeg/doc/faq.texi: 
[16:03] <CIA-31> ffmpeg: faq: fix typo.
[16:03] <CIA-31> ffmpeg: Reported-By: Clément BSsch
[16:08] <CIA-31> ffmpeg: 03Nicolas George 07master * rcfa2963b7e 10ffmpeg/MAINTAINERS: maintainers: add myself for recent works.
[16:21] <CIA-31> ffmpeg: 03Clément BSsch 07master * r5dfc7f7342 10ffmpeg/doc/ (ffmpeg.texi ffprobe.texi general.texi): doc: add Timecode documentation.
[16:50] <burek> what lib do i need to install to have x11grab indev?
[16:53] <ubitux> it seems you need --enable-gpl, and the lib with XShmCreateImage, so shared extensions or something
[16:53] <burek> I can't build static binary with that?
[16:53] <burek> # docs: 19.8 movsub needs to change to 19.8 mov2textsub
[16:54] <burek> # docs: 19.13 text2movsub
[16:55] <Compn> burek : x11 headers ?
[16:56] <burek> do you happen to know the name of the debian package? :)
[16:56] <Compn> used to be xorg-dev or so
[16:56] <Compn> might be x11-devel
[16:56] <Compn> i dunno what its called now ;\
[16:56] <burek> i tried libx11-dev
[16:57] <relaxed> xorg-dev
[16:58] <burek> so far i managed all these libs: http://pastebin.com/1vfwXGd8
[16:58] <burek> now, let me try to put x11 xorg-dev too :)
[16:59] <ubitux> are you trying to get a yes everywhere?
[16:59] <ubitux> (working on a fatelf with everything? a fate box?)
[16:59] <burek> well, I'm trying to build a big static GPL binary
[16:59] <burek> just like an EXE file
[16:59] <burek> which can be downloaded and run
[16:59] <ubitux> ok
[17:00] <relaxed> burek: you will also need --extra-ldflags="-static"
[17:00] <burek> I see, ok
[17:01] <ubitux> --enable-static only applies to the libav*, adding --extra-ldflags="-static" will embed all the lib*?
[17:01] <relaxed> last I tried it wouldn't work with librtmp
[17:01] <burek> relaxed, hmm i installed xorg-dev (and a bunch of required libs with it, too) but it didnt help produce x11grab indev
[17:02] <relaxed> look at config.log and use "apt-file search blah.h" to find package you need
[17:02] <burek> ok
[17:03] <relaxed> ubitux: I believe so
[17:03] <ubitux> i wonder where it stops; does it mean to embed all the sub-libs?
[17:05] <relaxed> yes
[17:05] <ubitux> so glibc etc?
[17:05] <relaxed> ldd ./ffmpeg doesn't not point to any libs
[17:05] <relaxed> -not
[17:05] <ubitux> fear, what size?
[17:06] <burek> libx11-dev, libxext-dev and libxfixes-dev - that's what apt-file says for those 3 files related to x11grab :) let me see now :)
[17:06] <relaxed> `du -hs ffmpeg` returns "17M ffmpeg"
[17:06] <ubitux> oh, not that much
[17:06] <ubitux> ok
[17:07] <ubitux> relaxed: are you linking with libx264 libvorbis etc?
[17:07] <relaxed> ubitux: https://sites.google.com/site/linuxencoding/builds
[17:08] <ubitux> ok, nice
[17:08] <burek> hmh, its playing with me :) doesn't want to give me x22grab indev grrr
[17:08] <burek> 11*
[17:10] <burek> well each day I remind myself what an idiot I am :) I forgot --enable-x11grab ^^
[17:10] <burek> it works now :) thx guys :)
[17:12] <relaxed> ha!
[17:16] <CIA-31> ffmpeg: 03Alexander Strasser 07master * r79f80f5c1f 10ffmpeg/ (configure libpostproc/postprocess.h): 
[17:16] <CIA-31> ffmpeg: build: Allow building old API/ABI libpostproc version
[17:16] <CIA-31> ffmpeg:  Allows our users to still build against a libpostproc with the old
[17:16] <CIA-31> ffmpeg: API/ABI. Distributions can use this option to defer the soname bump.
[17:16] <CIA-31> ffmpeg: Signed-off-by: Alexander Strasser <eclipse7 at gmx.net>
[17:16] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[17:16] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * rfa94f8a848 10ffmpeg/ (configure libavformat/libavformat.v): 
[17:16] <CIA-31> ffmpeg: buildsys: Fix shared lib build of ffserver.
[17:16] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[17:16] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * r1c910d2f11 10ffmpeg/libswscale/ (swscale_internal.h swscale_unscaled.c utils.c): 
[17:16] <CIA-31> ffmpeg: sws: Fix RGB0->alpha containing formats.
[17:16] <CIA-31> ffmpeg: Fixes Ticket869
[17:16] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[17:16] <CIA-31> ffmpeg: 03Paul B Mahol 07master * r6813450209 10ffmpeg/libavformat/ (ffmdec.c mov.c): 
[17:16] <CIA-31> ffmpeg: lavf: replace remaining use of deprecated get_strz()
[17:16] <CIA-31> ffmpeg: Signed-off-by: Paul B Mahol <onemda at gmail.com>
[17:16] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[17:16] <CIA-31> ffmpeg: 03Piotr Tomasik 07master * r62d2a75b02 10ffmpeg/libavformat/mov.c: 
[17:16] <CIA-31> ffmpeg: Added clockwise rotate values to metadata for 90 and 270 degrees
[17:16] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[17:26] <ubitux> is there a need of using --enable-runtime-cpudetect when doing packaging?
[17:27] <ubitux> for instance, if a package is build let's say on a see2 capable cpu, but will be deployed on a non-see2 capable cpu, it might cause invalid instruction or so without --enable-runtime-cpudetect?
[17:27] <kierank> it shouldn't
[17:27] <ubitux> is that the purpose of the option or i missed something?
[17:28] <ubitux> kierank: then what is it for?
[17:28] <kierank> dunno
[17:28] <burek> :)
[17:28] <ubitux> :D
[17:28] <burek> feed the pigs and don't touch anything :D
[17:28] <burek> while it works&
[17:29] <burek> hmh ERROR: vaapi not found
[17:29] <burek> I got libva from their git
[17:30] <burek> why would it throw an error..
[17:30] <burek> well, ok :) no libva support :D
[17:31] <ubitux> it seems CONFIG_RUNTIME_CPUDETECT is only used in libpp, and for cpu detect on ppc
[17:35] <CIA-31> ffmpeg: 03Tomas Härdin 07master * rd8531a1c18 10ffmpeg/libavformat/mxfdec.c: 
[17:35] <CIA-31> ffmpeg: mxfdec: Handle small EditUnitByteCount
[17:35] <CIA-31> ffmpeg: These are common with audio atoms. Without this the demuxer would read two
[17:35] <CIA-31> ffmpeg: bytes at a time for a mono 16-bit file.
[17:35] <CIA-31> ffmpeg: 03Tomas Härdin 07master * rb720915be1 10ffmpeg/libavformat/mxfdec.c: 
[17:35] <CIA-31> ffmpeg: mxfdec: Fix files > 2 GiB
[17:35] <CIA-31> ffmpeg: Accumulating into an int would cause overflow for files with essence
[17:35] <CIA-31> ffmpeg: containers larger than 2 GiB.
[17:35] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * rf1721fbc52 10ffmpeg/: 
[17:35] <CIA-31> ffmpeg: Merge remote-tracking branch 'tjoppen/mxf_fixes_20120124'
[17:35] <CIA-31> ffmpeg: * tjoppen/mxf_fixes_20120124:
[17:35] <CIA-31> ffmpeg:  mxfdec: Fix files > 2 GiB
[17:35] <CIA-31> ffmpeg:  mxfdec: Handle small EditUnitByteCount
[17:35] <CIA-31> ffmpeg: Merged-by: Michael Niedermayer <michaelni at gmx.at>
[17:37] <burek> hmm interesting..
[17:37] <Tjoppen> \o/
[17:37] <burek> configure went fine, until i added --extra-ldflags="-static"
[17:37] <burek> after that it started complaining like i dont have
[17:37] <burek> several libs installed, which i have
[17:38] <burek> and it wasnt complaining about those libs without --extra-ldflags="-static"
[17:52] <ubitux> TimN: haha i think you just noticed the issue i pointed out today on ffmpeg-devel
[17:52] <ubitux> (-t not working)
[17:52] <ubitux> so it might not be only for aresample
[17:53] <ubitux> TimN: can you confirm it works without using an audio filter?
[18:00] <burek> relaxed, something is wrong when I add  --extra-ldflags=-static
[18:00] <burek> it just starts telling me one by one none of my libraries is installed..
[18:00] <burek> without that switch, configure passes normally
[18:04] <michaelni> ubitux, libavfilter/libavfilter.a(af_pan.o):af_pan.c:(.text+0x6d6): undefined reference to `_swr_init'
[18:05] <michaelni> see any fate target that runs just 1013 tests
[18:05] <ubitux> fate is in the green here
[18:05] <michaelni> fate bug
[18:06] <michaelni> fate.ffmpeg.org bug
[18:06] <ubitux> mmh
[18:06] <michaelni> it should not be green imho
[18:06] <ubitux> isn't Nicolas' last commit supposed to fix that?
[18:06] <michaelni> hmm
[18:07] <ubitux> not the last actually, this one: http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=af21823ae0dc8f72446f9beb22563a72f485a57c
[18:07] <ubitux> how can i reproduce?
[18:08] <ubitux> mmh there are recent runs still without it
[18:10] <michaelni> it seems all the failing ones are still before nicolas commit
[18:10] <michaelni> so just waiting should fix it :)
[18:11] <ubitux> ok
[18:11] <ubitux> sorry about that&
[18:11] <ubitux> this make me think i need to fix af_aresample too
[18:11] <ubitux> before i push it
[18:12] <ubitux> michaelni: any idea why -t looks ignored or worse drop completely the audio output when using filters?
[18:25] <burek> i need a little help please
[18:25] <burek> http://pastebin.com/4hWWxZn1
[18:25] <burek> I managed to get that far
[18:26] <burek> and if I add --extra-ldflags=-static
[18:26] <burek> then configure starts complaining one by one for almost all libs
[18:26] <burek> with ERROR: <libname> not found
[18:27] <michaelni> ubitux, no idea, but if its not depending on new code trying an old version + bisect if it fails ...
[18:28] <ubitux> ok, will check later, 'got to go
[18:28] <ubitux> i added a enableshared fate instance btw, i hope it will ends before the box restarts
[18:28] <ubitux> cya :)
[19:20] <ubitux> isn't --enable-shared supposed to work out of the box?
[19:21] <ubitux> it seems to not be able to open shared object while running tests
[19:21] <ubitux> isn't a --rpath or something missing?
[19:24] <michaelni> hmm, last i tried i think --enable-shared was enough
[19:24] <ubitux> well linkage is ok
[19:24] <ubitux> but running the binary fails
[19:25] <ubitux> but maybe i did something wrong
[19:26] <ubitux> it works only if there is a ffmpeg installed on the system
[19:26] <ubitux> (so it resolves the installed lib in /usr/lib)
[19:27] <ubitux> while i can understand ./ffmpeg doesn't work with --enable-shared, it should at least work when installed
[19:27] <ubitux> but it seems not to be the case according to fate
[19:27] <ubitux> or maybe i should specify specific options?
[19:43] <michaelni> ubitux, can you try with a old version to make sure this didnt work previously?
[19:43] <michaelni> but LD_LIBRARY_PATH=libavcodec:... make fate -j4 
[19:43] <michaelni> should work
[19:46] <michaelni> "LD_LIBRARY_PATH=libavcodec:libavformat:libavfilter:libswscale make fate -j4" worked here
[20:15] <ubitux> it's doesn't look like a regression; the issue is present in the 0.7 branch
[20:15] <ubitux> and yes it can be workaround'ed with the ld library path
[20:15] <ubitux> something looks strange though
[20:16] <ubitux> configure:check_ldflags -Wl,-rpath-link=libpostproc:libswresample:libswscale:libavfilter:libavdevice:libavformat:libavcodec:libavutil
[20:16] <ubitux> this should work
[20:18] <ubitux> mmh wait&
[20:23] <ubitux> ideally i'd say we should have -rpath=libpostproc:libswresample:... for running in the build directory, and install should relink the binaries with -rpath=$prefix or something
[20:28] <ubitux> but the rpath behaviour looks quite tricky to deal with
[20:28] <ubitux> defining it seems to override the directories specified with -L
[20:28] <ubitux> so it may break the linkage with external libs
[20:29] <ubitux> why is this stuff so insane& :(
[21:16] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * rc77be3a35a 10ffmpeg/libavcodec/error_resilience.c: 
[21:16] <CIA-31> ffmpeg: error concealment: initialize block index.
[21:16] <CIA-31> ffmpeg: Fixes CVE-2011-3941 (out of bounds write)
[21:16] <CIA-31> ffmpeg: Found-by: Mateusz "j00ru" Jurczyk and Gynvael Coldwind
[21:16] <CIA-31> ffmpeg: Signed-off-by: Michael Niedermayer <michaelni at gmx.at>
[21:24] <ubitux> fate does not seem to appreciate ':' in the ldflags& but at least for display
[21:24] <ubitux> http://fate.ffmpeg.org/report.cgi?time=20120124200618&slot=x86_64-archlinux-gcc-enableshared
[21:25] <ubitux> the tests seem to pass though
[21:37] <burek> does ffmpeg have internal flac encoder/decoder
[21:39] <nevcairiel> yes
[21:40] <burek> ok, thx :)
[22:42] <CIA-31> ffmpeg: 03Carl Eugen Hoyos 07master * r76c3e76eb3 10ffmpeg/libavformat/ (isom.h mov.c): 
[22:42] <CIA-31> ffmpeg: Allow user to force reading mov alias from absolute path.
[22:42] <CIA-31> ffmpeg: Based on a work-around by Alex Zhukov.
[22:42] <CIA-31> ffmpeg: Fixes ticket #935
[22:59] <burek> how to tell cmake to build static libs?
[23:12] <CIA-31> ffmpeg: 03Janne Grunau 07master * r1d3a9e63e0 10ffmpeg/libavcodec/rv10.c: 
[23:12] <CIA-31> ffmpeg: rv10: verify slice offsets against buffer size
[23:12] <CIA-31> ffmpeg: Found by John Villamil <johnv at matasano.com> in fuzzed rv20 in mkv files.
[23:12] <CIA-31> ffmpeg: 03Paul B Mahol 07master * rd1ad6bdb6b 10ffmpeg/Changelog: 
[23:12] <CIA-31> ffmpeg: Changelog: restore version <next> header
[23:12] <CIA-31> ffmpeg: Signed-off-by: Ronald S. Bultje <rsbultje at gmail.com>
[23:12] <CIA-31> ffmpeg: 03Anton Khirnov 07master * r75e2025f57 10ffmpeg/avplay.c: 
[23:12] <CIA-31> ffmpeg: avplay: remove the -er option.
[23:12] <CIA-31> ffmpeg: Error recognition flags can and should be set directly with AVOptions.
[23:12] <CIA-31> ffmpeg: 03Anton Khirnov 07master * rdc7ad30fa5 10ffmpeg/libavformat/version.h: 
[23:12] <CIA-31> ffmpeg: lavf: postpone removing av_close_input_file().
[23:12] <CIA-31> ffmpeg: It has been deprecated only recently.
[23:12] <CIA-31> ffmpeg: 03Anton Khirnov 07master * r1381e9bc92 10ffmpeg/libavcodec/version.h: 
[23:12] <CIA-31> ffmpeg: lavc: postpone the removal of AVCodecContext.request_channels.
[23:13] <CIA-31> ffmpeg: vqa: set time base to frame rate as coded in the header.
[23:13] <CIA-31> ffmpeg: According to Multimedia Wiki documentation, the frame rate is not always 15,
[23:13] <CIA-31> ffmpeg: and the actual value can be found in the header.
[23:13] <CIA-31> ffmpeg: 03Justin Ruggles 07master * r220506d23f 10ffmpeg/ (8 files in 2 dirs): 
[23:13] <CIA-31> ffmpeg: avcodec: add a new codec_id for CRYO APC IMA ADPCM.
[23:13] <CIA-31> ffmpeg: The stereo layout and extradata is significantly different from that in
[23:13] <CIA-31> ffmpeg: Westwood IMA ADPCM, so a separate codec_id is warranted.
[23:13] <CIA-31> ffmpeg: 03Justin Ruggles 07master * r7e813d5933 10ffmpeg/libavformat/westwood_vqa.c: 
[23:13] <CIA-31> ffmpeg: vqa: clean up audio header parsing
[23:13] <CIA-31> ffmpeg: Fix setting of bit_rate and bits_per_coded_sample.
[23:13] <CIA-31> ffmpeg: Ask for sample for unsupported VQA versions.
[23:13] <CIA-31> (22 lines omitted)
[23:13] <CIA-31> ffmpeg: 03Alex Converse 07master * refe68076da 10ffmpeg/libavcodec/aacenc.c: aacenc: Fix identification padding when the bitstream is already aligned.
[23:13] <CIA-31> ffmpeg: 03Justin Ruggles 07master * rbe14a37066 10ffmpeg/libavformat/westwood_aud.c: 
[23:13] <CIA-31> ffmpeg: aud: fix time stamp calculation for ADPCM IMA WS
[23:13] <CIA-31> ffmpeg: also allows for removing some unused context fields
[23:13] <CIA-31> ffmpeg: 03Michael Niedermayer 07master * r1d9569f9e8 10ffmpeg/: (log message trimmed)
[23:13] <CIA-31> ffmpeg: Merge remote-tracking branch 'qatar/master'
[23:14] <CIA-31> ffmpeg:  aud: fix time stamp calculation for ADPCM IMA WS
[23:14] <CIA-31> ffmpeg: 03Justin Ruggles 07master * rb8dd555c63 10ffmpeg/libavformat/westwood_aud.c: 
[23:14] <CIA-31> ffmpeg: aud: remove unneeded field, audio_stream_index from context
[23:14] <CIA-31> ffmpeg: There is only one stream, so it will always be index 0.
[23:14] <CIA-31> ffmpeg: This also allows for removal of the private context.
[23:14] <CIA-31> ffmpeg: 03Anton Khirnov 07master * r941e9f2238 10ffmpeg/ (5 files in 2 dirs): lavd: remove deprecated v4l grab device.
[23:14] <CIA-31> ffmpeg: 03Anton Khirnov 07master * raf0292f33a 10ffmpeg/libavcodec/version.h: 
[23:14] <CIA-31> ffmpeg: lavc: postpone removing old audio encoding and decoding API
[23:14] <CIA-31> ffmpeg: It has been deprecated only recently.
[23:16] <burek> anyone knows how to tell cmake to build static libs?
[23:17] <burek> I cant build libv4l2 as a static lib
[23:22] <Daemon404> doesnt v42l have an autotools based configure too?
[23:22] Action: Daemon404 loathes cmake
[23:27] <burek> hmh
[23:28] <burek> I think not
[23:29] <burek> cmake like structure..
[23:29] <burek> oh sorry
[23:29] <burek> not cmake, but without configure..
[23:29] <burek> ive mixed it with another lib..
[23:30] <burek> that's what happens when you build all day long :)
[23:30] <burek> it has got no autoconf or configure
[23:30] <burek> i can just type make
[23:30] <burek> and thats it
[23:30] <Daemon404> custom makefile then
[23:30] <burek> there is one
[23:31] <Daemon404> where is this package located?
[23:31] Action: Daemon404 only sees v4l-utils
[23:31] <burek> http://pastebin.com/tKqch6qs
[23:31] <burek> i've downloaded it from here http://linuxtv.org/downloads/v4l-utils/
[23:32] <Daemon404> http://git.linuxtv.org/v4l-utils.git/tree
[23:32] <Daemon404> it has autotools files
[23:32] <burek> omg they have git
[23:32] <burek> i couldn't find it at all.. only online version
[23:32] <burek> how can i use it like: git clone..
[23:32] <burek> git clone http://git.linuxtv.org/v4l-utils.git ?
[23:33] <Daemon404> why the heck do you want static libv42l anyway?
[23:33] <Daemon404> im not sure it's ven possible (a la glibc)
[23:33] <burek> well, I need it because
[23:33] <burek> I'm trying to build static ffmpeg
[23:34] <burek> and when i add --extra-ldflags=-static
[23:34] <burek> then ffmpeg's configure starts complaining about all kinds of things
[23:34] Action: Daemon404 cannot comment here
[23:34] <burek> among them it can't find libv4l2.a
[23:34] <Daemon404> but that sounds wrong.
[23:34] <burek> :/
[23:35] <Daemon404> and unless you link against something liek uclibc or w/e
[23:35] <Daemon404> it isnt really static
[23:35] <Daemon404> glibc fails @ static
[23:35] <burek> do you have a suggestion how to compile ffmpeg binary to be like exe file
[23:35] <burek> so i can just download it and execute on another
[23:35] <burek> (similar) machine
[23:38] <burek> http://pastebin.com/KZfanbuC
[23:38] <burek> this is the error from configure
[23:38] <burek> and this is from config.log: http://pastebin.com/8087YCTD
[23:44] <burek> Cloning into v4l-utils... warning: remote HEAD refers to nonexistent ref, unable to checkout. :) nice.. :)
[23:52] <ubitux> hi saste :)
[23:53] <ubitux> saste: did you notice the afilter issue?
[23:54] <ubitux> saste: ./ffmpeg -f lavfi -i amovie=a.mp3,aresample=8000 -t 10 -y out.wav
[23:54] <ubitux> with the current version ’ no audio
[23:54] <ubitux> it seems related to Tim's report on ffmpeg-user
[23:54] <ubitux> i still didn't check if it was a regression or not
[23:54] <ubitux> but maybe you have an idea
[23:55] <ubitux> note that the new version with libswr do the exact oppposite: all the audio is kept, -t being ignored
[00:00] --- Wed Jan 25 2012

More information about the Ffmpeg-devel-irc mailing list