[FFmpeg-user] mmsh streams and immense buffering

Carl Eugen Hoyos cehoyos at ag.or.at
Wed May 23 22:46:02 CEST 2012

Patrick Cornwell <patrick <at> cornwell.org> writes:

> I'm asking questions
> within my scope of knowledge and you intentionally avoid helping
> specifically what I ask, instead pointing out what is missing in my
> responses, where clearly you're able to replicate my problem.

I am not able to reproduce (two of) your problem(s).
ffmpeg does not crash here, the reason might be that my FFmpeg is not 
compiled with x264 support, but I don't know because as far as I know 
you did not test without -vcodec libx264
(Note that crashes are important, so there is a high chance that 
the crash is fixed once it is either reproduced or a backtrace is 

ffplay works fine here (without any waiting), as long as you do not post 
your ffplay command line together with complete, uncut output, I cannot 
explain why it works for me but not for you.

ffmpeg does not convert the problematic streams here, I do not know 
why, but if you look at the ffplay console output, it indicates 
that FFmpeg is unable to correctly read the timestamps
(I tried to explain that in my very first mail iirc), that 
seems like a reason, and I do not know how to fix it.
(I tried -copyts and it did not help.)

Carl Eugen

More information about the ffmpeg-user mailing list