[FFmpeg-user] Audio sync issues when transcoding Hauppauge HDPVR content

Scott Naef snaef1 at mail.brookdalecc.edu
Tue Jan 15 22:20:46 CET 2013


Thank you for the help.  My sample source file input.mpg is at:

My resulting output.mp4 is at:

My ffmpeg command is:
ffmpeg  -i input.mpg -async 1 -y -vcodec libx264 -r 25 -b:v 1268k -s 
512x368 -acodec libmp3lame -threads 2 output.mp4

Ouput log:


I tried your -vsync 1 option but it did not work wither.  I also tried 
-vsync 0 and interestingly this option produced a slew of PTS / DTS 
conflict errors ( log is at: 
https://docs.google.com/file/d/0BzSQuUjfkFN1U1FaME43RjdBYTQ/edit ) but 
that did not work either.


On 1/15/2013 2:35 PM, Carl Eugen Hoyos wrote:
> Scott Naef <snaef1 <at> mail.brookdalecc.edu> writes:
>> I have tried several options in FFMPEG such as
>> -async 1 but nothing I try seems to work.  I always
>> end up with about 1.5 second delay in video from audio.
> Please provide a sample that is long enough to
> easily (!) see the desync.
> And please provide the command line you tested
> for transcoding (ideally for the sample you
> provide) together with complete, uncut console
> output.
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list