[FFmpeg-user] No luck with live stream from ffmpeg to ffserver

En Figureo Canal figureo56.com at gmail.com
Sun May 3 00:50:25 CEST 2015

I haven’t had much luck deploying ffserver, nothing works out for me
streaming live from ffmpeg to ffserver. Had different problems, I don’t
know if my configuration is correct but, can’t really get ffsever to do
what I need and things are just frustrating me.

The last error message I’m getting is av_interleaved_write_frame(): Unknown
error along with Past duration too large. I’ve read somewhere saying that
it might be incompatible versions of ffmpeg, which I found odd and stupid.

I believed ffmpeg should work with any current version.

First, I’m trying to do a live stream using a capture card I’ve installed
and/or using VidBlaster but, haven’t been able. Audio can be done easily
but not Video.

Here’s my ffmpeg conf:

<Feed channel2.ffm>
>         File /root/channel2.ffm
>         FileMaxSize 64M
> </Feed>
> <Stream channel2.sdp>
>         Feed channel2.ffm
>         Format rtp
>         VideoCodec libx264
> #       VideoFrameRate 30
> #       VideoSize 640x360
>         VideoBitRate 1000
>         # Audio settings
>         AudioCodec libmp3lame #libfdk_aac
>         AudioSampleRate 41000
>         AudioBitRate 96
>         AudioChannels 2 #this is creating problem
>  #      AVOptionAudio flags +global_header
>         MaxTime 0
>         AVOptionVideo me_range 16
>         AVOptionVideo qdiff 4
>         AVOptionVideo qmin 4
>         AVOptionVideo qmax 40
>         #AVOptionVideo good
> #       AVOptionVideo flags +global_header
>         # Streaming settings
>         PreRoll 10
>         StartSendOnKey
> NoDefaults
> </Stream>

When I send the feed to the server I get the previous mentioned error. What
exactly am I doing wrong? I’ve tried different combinations to send the
feed but nothing works, this is the last conf to send to the server:

Ffmpeg –re –rtbufsize 1500M –f dshow –I video=”input”:audio=”input” –acodec
libmp3lame –ar 44100 –ab 96k –vcodec libx264 –f flv

I've even tried feeding a video from my pc to the server, and still no luck.

Please guide me to the correct path to get this working, thanks.

More information about the ffmpeg-user mailing list