[FFmpeg-user] SDL2 over x11: “SDL: could not set video mode - exiting”

Jeff secjeff at gmail.com
Tue Nov 28 01:57:08 EET 2017

I’m sorry if this is covered somewhere else, but I can’t seem to find a
solution on this mailing list, the SDL2 forums, or through google searches
anywhere. This seems to be somewhat common, but again, no definitive

When I try to run a SDL2 application (e.g., ffplay) over X11 via SSH and
Exceed, I receive the following error: “*SDL: could not set video mode -

This only occurs with SDL2 applications (I’ve tried glxgears as well).
Non-SDL, X-Windows applications work fine over the connection (e.g.,
terminal, xclock, etc). I’m able to launch ffplay locally on the machine
itself, so it just fails over SSH forwarding.

The DISPLAY variable is set properly (and works for other apps as

I’ve tried setting the *SDL_VIDEODRIVER to x11* as well, but still no luck.
Is there something I’m missing? I have all the X11 (and DEVEL) libraries
installed. SDL2 was configured with the standard ./configure options and
shows X11 support in the config file.

Someone on the SDL forum suggested it might be trying to use OpenGL vs. the
default X11 driver and that could be the root of the issue, but I don't
think so, nor do I know how to verify this.

Please advise. Thank you for your time.

More information about the ffmpeg-user mailing list