[FFmpeg-user] Understanding how to use FFmpeg on macOS

Tangier Clarke tangierc at gmail.com
Sat Mar 21 02:14:48 EET 2020

Hello Jim.  I’ll answer you questions or confirm your responses in order.

Yes, I am trying to isolate where the problem is because the type of video files I am using, I have been using for a long time, with the same workflow.
I am not sure that FFprobe was used in the pre Catalina version of LTC Convert.  I only say that because I have bee speaking with the developer at length by email (providing me with debug versions of the app) and he’s mentioned that ffprobe was required in the most recent build he gave me…version 6.04 didn’t require it, but 6.05 did.  Then there are shared and static FFmpeg versions; one self contained on the mac, the other containing libraries, a bin folder, and other files.
To be more specific by the way: The feature I am using is LTC Convert’s ability to take a provided Quicktime movie, scan it for Linear Time Code (LTC), and alter the timecode of the Quicktime file using the LTC.  This is used to sync with audio files from a device the provided the master LTC to the cameras.
I have been working with the developer and the response is that some files work and some don’t.  Yet I can’t possibly understand (if this is the case) why FFmpeg would remove support for AVC or H.264 video files even when wrapped as an .mov.
LTC Convert requires that it is passed a Quicktime file. I do not alter the underlying structure of the initial video file embedded in an .mts stream.  It is simply rewrapped in an .mov.  Again, I’ve been doing this for a few years with previous versions.
In previous versions though, I do not recall having to separately install FFmpeg or FFprobe.  Only the app itself.
I downloaded from Zeranoe because my communications with the developer showed me that this is the version he used or at least suggested.  I initially got my installations from https://www.ffmpeg.org <https://www.ffmpeg.org/>   I am not sure of the difference between the two.
I sent two sample clips to the developer to test because I got different results for these two Quicktime movies yet they’re the same format. I haven’t heard back yet.
The app instructions for installing FFmpeg are in the manual.  Here the are verbatim below:
I do not understand what could be causing these Quicktime movies to fail the compatibility test before the app altering the timecode.

4.3 Get FFmpeg!

You need to have FFmpeg and FFprobe installed.
If you don't have it, the application will ask you where FFmpeg is, and assume FFprobe is in the same folder. (You can also specify a different binary than default, if you want to.)

If unsure, get a (static!) binary from here:


Unzip the file, and go into the BIN folder.
There you'll find FFmpeg and FFprobe. (Or FFmpeg.exe / FFprobe.exe)
On Mac, drag that to your Applications folder.
On Win, put it 'somewhere', run LTCconvert, and point it to where FFmpeg lives.

If the the application can't find FFmpeg:

Under the 'Setup' menu, you'll find 'Pick FFmpeg' at the bottom. Use that to point LTCconvert to the version of FFmpeg you want to use. Again, it assumes FFprobe is in the same folder, so make sure it is! 

Thanks for the help.


> On Mar 20, 2020, at 4:39 PM, Jim DeLaHunt <list+ffmpeg-user at jdlh.com> wrote:
> On 2020-03-20 14:26, Tangier Clarke wrote:
>> Hello folks.
>> I am using a software on the Mac called LTC Convert (the Catalina version) that relies on FFmpeg.  Lately, Quicktime clips that have been compatible in the pre Catalina version of the app are no longer working for a timecode rewrite.  I believe this has to be due to FFmpeg. I am trying to isolate if I have installed it incorrectly or if there’s something I am not doing correctly.  The video files are ones that FFmpeg supports I believe.  The message I get is No compatible Quicktime files in this batch.  The app also relies on ffpbobe
>> Here’s what I’ve done.  The Quicktime movies are AVCHD clips from a Canon C100, rewrapped into .mov files by EditReady.  They are H.264 with linear PCM audio and 192-x1080.
>> Please see if you notice anything that may be suspect:
>> Downloaded this file ffmpeg-20200315-c467328-macos64-static
>> Move the folder to my Applications folder
>> Pointed the application to my installation of FFmpeg located in a bin folder (with ffplay and ffprobe) and the app confirmed this is OK with a success dialogue message.
>> Import Quicktime mov clips into the app and attempt to alter the timecode, but this yields  this message: No compatible Quicktime files in this batch.
>> Did FFmpeg remove compatibility for this format?
>> Are there other libraries or things I need?
>> I tried a shares installation version before with no luck.
>> I’ve tried an install from Zeranoe and home-brew as well.
>> Thanks.
>> Tangier
> Hello, Tangier:
> I can sympathise. It's frustrating to have a system which used to work and stops working. Let me see if I can help you take your diagnosis a step further.
> It looks like you are using LTC Convert which in turn uses ffmpeg and ffprobe. This combination has stopped working right for you. The next trick is to figure out what changed to make this stop working: LTC Convert, or ffmpeg/ffprobe, or something about your input files.
> You will rapidly discover that people on this list only wants to support problems which involve ffmpeg or ffprobe in isolation. They will want you to run a these apps on a command line, then post the command line plust the complete, uncut command line output to this list.  You are unlikely to get help with LTC Convert.
> Since LTC Convert is what uses ffmpeg, have you tried bringing this problem up with the support for LTC Convert? What was their response?  Did they help you isolate the problem to ffmpeg/ffprobe behaviour?  Did they help you craft a command line invocation which demonstrates the problem?
> When you "Downloaded this file ffmpeg-20200315-c467328-macos64-static", from where did you download it?  That filename structure looks different from the filenames linked to from <http://ffmpeg.org/download.html>. This page links to a Mac-specific page, /static FFmpeg binaries for macOS 64-bit/, <https://evermeet.cx/ffmpeg/>. The filename I see look like, *ffmpeg-96999-g1e3d4fa0fb.7z* or *ffmpeg-96999-g1e3d4fa0fb.7z* . This list will be more helpful if you can reproduce your bug with the current snapshot of ffmpeg downloaded from this project's own servers.
> I'm not an official with the FFmpeg project or anything, but in my experience the tool doesn't often remove support for currently-used formats. If something stopped working, "ffmpeg withdrew support" is an unlikely cause. "Command line uses wrong options" or "File format is different than I expected" are more likely, with "bug in ffmpeg" some ways behind that.
> I hope this is helpful. Best regards,
>     —Jim DeLaHunt, software engineer, Vancouver, Canada
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
> To unsubscribe, visit link above, or email
> ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".

More information about the ffmpeg-user mailing list