[FFmpeg-user] Understanding how to use FFmpeg on macOS

Jim DeLaHunt list+ffmpeg-user at jdlh.com
Sat Mar 21 01:39:20 EET 2020

On 2020-03-20 14:26, Tangier Clarke wrote:
> Hello folks.
> I am using a software on the Mac called LTC Convert (the Catalina version) that relies on FFmpeg.  Lately, Quicktime clips that have been compatible in the pre Catalina version of the app are no longer working for a timecode rewrite.  I believe this has to be due to FFmpeg. I am trying to isolate if I have installed it incorrectly or if there’s something I am not doing correctly.  The video files are ones that FFmpeg supports I believe.  The message I get is No compatible Quicktime files in this batch.  The app also relies on ffpbobe
> Here’s what I’ve done.  The Quicktime movies are AVCHD clips from a Canon C100, rewrapped into .mov files by EditReady.  They are H.264 with linear PCM audio and 192-x1080.
> Please see if you notice anything that may be suspect:
> Downloaded this file ffmpeg-20200315-c467328-macos64-static
> Move the folder to my Applications folder
> Pointed the application to my installation of FFmpeg located in a bin folder (with ffplay and ffprobe) and the app confirmed this is OK with a success dialogue message.
> Import Quicktime mov clips into the app and attempt to alter the timecode, but this yields  this message: No compatible Quicktime files in this batch.
> Did FFmpeg remove compatibility for this format?
> Are there other libraries or things I need?
> I tried a shares installation version before with no luck.
> I’ve tried an install from Zeranoe and home-brew as well.
> Thanks.
> Tangier
Hello, Tangier:

I can sympathise. It's frustrating to have a system which used to work 
and stops working. Let me see if I can help you take your diagnosis a 
step further.

It looks like you are using LTC Convert which in turn uses ffmpeg and 
ffprobe. This combination has stopped working right for you. The next 
trick is to figure out what changed to make this stop working: LTC 
Convert, or ffmpeg/ffprobe, or something about your input files.

You will rapidly discover that people on this list only wants to support 
problems which involve ffmpeg or ffprobe in isolation. They will want 
you to run a these apps on a command line, then post the command line 
plust the complete, uncut command line output to this list.  You are 
unlikely to get help with LTC Convert.

Since LTC Convert is what uses ffmpeg, have you tried bringing this 
problem up with the support for LTC Convert? What was their response?  
Did they help you isolate the problem to ffmpeg/ffprobe behaviour?  Did 
they help you craft a command line invocation which demonstrates the 

When you "Downloaded this file ffmpeg-20200315-c467328-macos64-static", 
from where did you download it?  That filename structure looks different 
from the filenames linked to from <http://ffmpeg.org/download.html>. 
This page links to a Mac-specific page, /static FFmpeg binaries for 
macOS 64-bit/, <https://evermeet.cx/ffmpeg/>. The filename I see look 
like, *ffmpeg-96999-g1e3d4fa0fb.7z* or *ffmpeg-96999-g1e3d4fa0fb.7z* . 
This list will be more helpful if you can reproduce your bug with the 
current snapshot of ffmpeg downloaded from this project's own servers.

I'm not an official with the FFmpeg project or anything, but in my 
experience the tool doesn't often remove support for currently-used 
formats. If something stopped working, "ffmpeg withdrew support" is an 
unlikely cause. "Command line uses wrong options" or "File format is 
different than I expected" are more likely, with "bug in ffmpeg" some 
ways behind that.

I hope this is helpful. Best regards,
     —Jim DeLaHunt, software engineer, Vancouver, Canada

More information about the ffmpeg-user mailing list